96 mercury sable wagon

Reply

  #1  
Old 09-08-08, 02:49 PM
shel.'s Avatar
Member
Thread Starter
Join Date: Sep 2008
Location: Toronto Ontario Canada
Posts: 14
96 mercury sable wagon

Neighbour just came over to let me know my headlights are on. Out I go to turn them off and see that the switch is off !

also a month ago I notice that engine is racing in gear when it is hot , in nutreul its Idiling very fast! I know of the valve controled electricaly on the air intake and it tested good!

any sugestions!!!
 
Sponsored Links
  #2  
Old 09-08-08, 08:31 PM
Speedwrench's Avatar
Member
Join Date: Apr 2008
Location: Oklahoma
Posts: 1,698
check for a relay stuck, does your vehicle have day time running lights? could be crack in a vac line for the running fast. try clamping off vac lines at the source to see if that changes anything. inspect your plenum from the air filter back to the engine for leaks or cracks.

are you going to cowboy up or just lay there and bleed?
 
  #3  
Old 09-09-08, 12:25 PM
shel.'s Avatar
Member
Thread Starter
Join Date: Sep 2008
Location: Toronto Ontario Canada
Posts: 14
Now that you mention it my car does have daytime running lights but they are very dim. I think that's what is stuck on now because they are brighter, but when I turn the switch on they get even brighter, then of course the high beems are the brightest. HEY you mean I got my day time running lights back? Just need them to shut off when the car is off!!!

Now today its seems most of the electrical system is acting up. I hear the colant fan running when engine is cool.
The dash lights and radio lights are flickering
and power was lost to the engine while I left for work and coming home.
 
  #4  
Old 09-09-08, 08:20 PM
Speedwrench's Avatar
Member
Join Date: Apr 2008
Location: Oklahoma
Posts: 1,698
since about the only thing those things have in common would be a ground i would start by checking system grounds. make sure all of your grounds are good and then if still haveing problems you will have to start checking relays or possibley diodes.

Murphy was an optimist
 
  #5  
Old 09-10-08, 01:02 PM
shel.'s Avatar
Member
Thread Starter
Join Date: Sep 2008
Location: Toronto Ontario Canada
Posts: 14
Thanks again speedwrench. All electrical in the car worked find today, except for my head light problem. Somthing I failed to mention was when it is damp or wet in the morning is when I have the electrical problem. its like I am loseing spark! The engine just spiters, jerks ,cough until it dry's up some.

Ignition, coil ??? Don't know...YET!
 
  #6  
Old 09-10-08, 01:10 PM
Member
Join Date: Oct 2000
Location: Livonia, Michigan
Posts: 923
A sick engine when it's wet or damp out usually means you need new ignition wires.

The way to verify bad ignition wires is to wait for dark, open the hood with the engine idling, and spray water on the ignition wires. If you see arcing anywhere near the wires than they need to be replaced. If they're really bad, you can see arcing without wetting them down.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes