2004 Ford Explorer Idle

Reply

  #1  
Old 09-16-08, 09:39 AM
Member
Thread Starter
Join Date: Jul 2008
Posts: 17
2004 Ford Explorer Idle

I recently bought an Explorer with 55,000 miles and though being a wreck rebuild with prior salvage tiltle is in excellent shape except for a rough idle when the air conditioner is on. My local garage said I needed a tune up so I installed plugs, wires, and new air filter and cleaned the throttle body with spray. Idles perfect without AC but when you turn on AC it starts idling as though it has a regular miss. Turning off the AC won`t fix the rough idle immediately but engine will return to normal after a bit of driving, stopping, and starting. Any suggestions? Service engine light is on. Could I have sensor problems? BTW, it idles at only 500 rpms. Is that normal?Beer 4U2
 
Sponsored Links
  #2  
Old 09-16-08, 11:55 AM
Member
Join Date: Sep 2008
Location: northest U.S.
Posts: 158
could be? you should visit an autozone or someone who can pull the service engine soon light code and post it then we can better help you. What size engine does it have?
 
  #3  
Old 09-16-08, 08:09 PM
Member
Thread Starter
Join Date: Jul 2008
Posts: 17
4.0 v-6 I`ll try auto zone tomorrow am. Thanks.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'