Climate control

Reply

  #1  
Old 09-25-08, 09:39 AM
Member
Thread Starter
Join Date: Nov 2002
Location: Canada
Posts: 105
Climate control

I have a 1999 GMC Envoy 4.3L auto and no power to the climate control , fan, ac, defrost none of the settings work and this just happened one day . All fuses are good indash and engine compartment. Any ideas what could be the problem. And also totally unrelated since its been going much longer than all this started a relay under the dash on the passenger side keeps clicking while driving and intermittantly , anyone knows what this may be? Thanks.
 
Sponsored Links
  #2  
Old 09-25-08, 11:45 AM
Member
Join Date: Sep 2008
Location: Wisconsin
Posts: 82
just because the fuses are doesn;t mean they have power check to see if the fuses have batt + with key on u may have a bag ignition switch or fuse panel both which also could cause a relay to click on and off
 
  #3  
Old 09-25-08, 03:04 PM
shadetreeall's Avatar
Member
Join Date: Sep 2008
Location: nm
Posts: 25
mech

GM had a problem with the fan control switch,s back than. they heat up and melt the connector for the wire harness on the back side of the switch and cause a draw and cause the relay to go on and off. pull it and look at the wires.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes