cant get brights to shut off

Reply

  #1  
Old 09-30-08, 09:09 PM
Member
Thread Starter
Join Date: Sep 2008
Location: ohio usa
Posts: 4
Cool cant get brights to shut off

just bought a century wagon i can only use the brights i found out any ideas on how to fix this the haynes manual was no help at all ?
 
Sponsored Links
  #2  
Old 09-30-08, 09:23 PM
Forum Topic Moderator
Join Date: Oct 2002
Location: Hamilton County, Ohio
Posts: 4,292
How old is it? If the turn signal stalk is not switching the lights, I would suspect either a bad switch or a stuck/bad high beam relay.
 
  #3  
Old 09-30-08, 09:40 PM
Member
Thread Starter
Join Date: Sep 2008
Location: ohio usa
Posts: 4
1993 wagon 3.3 liter not to bad of a car
 
  #4  
Old 10-01-08, 02:55 AM
Member
Join Date: Jun 2008
Location: Eastern Georgia
Posts: 486
you have a bad dimmer switch. it is mounted on the steering column.
 
  #5  
Old 10-01-08, 06:24 AM
Member
Thread Starter
Join Date: Sep 2008
Location: ohio usa
Posts: 4
Question

how would i go about replacing that is it a pain or is it pretty easy
 
  #6  
Old 10-01-08, 07:46 PM
Forum Topic Moderator
Join Date: Oct 2002
Location: Hamilton County, Ohio
Posts: 4,292
It looks like a pain. Start by properly disabling the steering wheel air bag, remove the steering wheel, and go from there.
The link below explains the procedure.


http://www.autozone.com/shopping/rep...00c152800cc6f3
 
  #7  
Old 10-01-08, 08:46 PM
Member
Thread Starter
Join Date: Sep 2008
Location: ohio usa
Posts: 4
it figures the hanyes book tell how to do all that jazz thanks fer the help
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes