abs light

Reply

  #1  
Old 10-09-08, 04:12 PM
Member
Thread Starter
Join Date: Apr 2008
Location: usa
Posts: 16
abs light

I have a 98 chevy malibu. The abs light was onwhen we bought it, It needed hub assy's so I changed out the worst one and the light went out, .... for a week, then once in a while, I figured when I replced the other hub it would go out, this weekend I replaced it and the rotor and pads on the drivers side, started the car and the light didn't come on then I changed the rotor and pads on the passenger side, now the lights on all of the time, I rechecked the sensor plugs on both hubs , no luck, can somebody help?? thanks
 
Sponsored Links
  #2  
Old 10-09-08, 04:19 PM
HotxxxxxxxOKC's Avatar
Banned. Rule And/Or Policy Violation
Join Date: Jul 2006
Location: USA
Posts: 8,044
Have you checked the gap between the sensor and the abs doohookie (looks like a gear, called the tone ring)?

You probably damaged the sensors.
 
  #3  
Old 10-09-08, 04:49 PM
Member
Thread Starter
Join Date: Apr 2008
Location: usa
Posts: 16
abs light

the sensor and hub/ bearing assy are one piece and sealed, the problem "seemed" to be fixed after I replaced the hub assy, but when I changed out the brakes on the other side (didn't touch the sensor/ hub assy) the light came back on
 
  #4  
Old 10-09-08, 06:01 PM
Member
Join Date: Sep 2008
Location: Wisconsin
Posts: 82
Check the wire harnesses and conections for breaks. U might have to get a abs trouble code to pin point the cause most repair shops will read codes for free . U might also have a bad new part which has happened before
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes