1990 Honda Accord Engine RPM Racing

Reply

  #1  
Old 10-29-08, 11:15 AM
D
Member
Thread Starter
Join Date: Jun 2005
Location: United States
Posts: 334
Received 0 Votes on 0 Posts
1990 Honda Accord Engine RPM Racing

1990 Honda Accord, 4 Dr, LX, AT, 191K. Coolant hose leaks coolant last night while driving home about 13 miles away from home. Temperature raised to "High". Stop twice (10-15 mins each for about every 4 miles) and continue to drive home. Starting about 2 miles away from home, engine light was on all the time, then Battery/Oil/Break light (forgot which one exactly) was flashing after about 1 mile. After 2-3 seconds, then S (sport) light was flashing. I started engine tried to check where is leaking this morning, I can't find where it leaks since engine is still cold and the presure may still low. However, engine has very lound noise and engine RPM is racing between 1200 and 1800 r/min every half a second. I can also see engine is trying to move every time it races between 1200 and 1800 r/min. Does anyone knows what the problem is? Is it a diy job (I do most of car fixing myself including break, rotor, axle assembly, wheel bearing, ignition switch, etc.) How much will it cost me to have professional mechanic fix this in east/south of San Fr ancisco Bay area? This is urgent as I need it to drive to work and I can't affort for a new car. Any suggestions/comments are appreciated and thanks in advance!
 
  #2  
Old 10-29-08, 12:06 PM
D
Member
Thread Starter
Join Date: Jun 2005
Location: United States
Posts: 334
Received 0 Votes on 0 Posts
By the way, I also see lots of smog coming out from exaust pipe.
 
  #3  
Old 10-29-08, 05:55 PM
D
Member
Thread Starter
Join Date: Jun 2005
Location: United States
Posts: 334
Received 0 Votes on 0 Posts
Fixed leaking engine heater hose and filled coolant. White smog is gone. No engine light on or other lights flashing. Engine isn't racing any more. Car runs OK. The only thing is engine a little bit noise and it sounds not running smoothly. Any idea of what could damage?
 
  #4  
Old 11-03-08, 11:00 PM
D
Member
Thread Starter
Join Date: Jun 2005
Location: United States
Posts: 334
Received 0 Votes on 0 Posts
Just found out engine temperature raise to high at stop and go traffic or stop at red light. Temperature drop back to normal as long as above 40 miles per hour. Any expert here can give your comments? Thanks in advance!
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description: