Turn Signal Light

Reply

  #1  
Old 11-02-08, 10:57 AM
Member
Thread Starter
Join Date: Jan 2007
Location: NJ
Posts: 453
Turn Signal Light

My turn signals on my dash is a solid light when I pull the turn signal down or up to turn to left or right. It does not flicker. What's wrong?
 
Sponsored Links
  #2  
Old 11-02-08, 11:29 AM
Forum Topic Moderator
Join Date: Mar 2005
Location: USA
Posts: 44,014
Probably the flasher but check the bulbs on the outside first to make sure they light up.
 
  #3  
Old 11-02-08, 02:33 PM
Member
Join Date: Sep 2008
Location: Wisconsin
Posts: 82
Also hit the hazard button and see if the turn signals blink.this is a good way to see if the bulbs are good. (what is the make,model ,year)
 
  #4  
Old 11-02-08, 07:14 PM
Member
Thread Starter
Join Date: Jan 2007
Location: NJ
Posts: 453
It's a 1995 camry. All the turn signal bulbs work in the front and back for both left and right side.

What's a flasher? Is that easy to change?
 
  #5  
Old 11-03-08, 03:47 AM
Forum Topic Moderator
Join Date: Mar 2005
Location: USA
Posts: 44,014
A flasher is a round [sometimes square] cylinder with 2 plugs on the end that interupt the current to make the signal lights blink.

They always used to be under the dash next to the parking brake [near the fuse box] but I don't know where it would be on your car. If your 4-way flashers work, turn them on and listen - the flasher for the 4-ways and turn signal are usually close together. The flashers are often interchangable.
 
  #6  
Old 11-03-08, 11:46 AM
Member
Thread Starter
Join Date: Jan 2007
Location: NJ
Posts: 453
The flashers would be solid light too when I turned them on.

For some reason, the turn signals and flasher work today but did not work all weekend. Weird!

What could be going on?
 
  #7  
Old 11-03-08, 04:33 PM
Forum Topic Moderator
Join Date: Mar 2005
Location: USA
Posts: 44,014
It might be a bad connection. The turn signals on my 90 jeep have been acting up lately. Several times they quit working for a short time, today they quit while I was in town. I was going to buy a new flasher but I noticed when I unplugged the old one and then plugged it back in - they started working. I need to clean the the prongs and then I probably won't have any more problems.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes