97 Saturn SL SES Light.

Reply

  #1  
Old 11-18-08, 11:28 AM
Member
Thread Starter
Join Date: Mar 2008
Location: New Jersey
Posts: 17
Question 97 Saturn SL SES Light.

I have a 97 Saturn SL. The SES light only comes on after we get alot of rain. It will come on and stay on until the weather clears. I have had the code read by Autozone and it points to a cam position sensor. Only thing is that a 97 Saturn SL does not have a cam position sensor. It is definately weather related but I don't have a clue where to start on this. I don't see any frayed wires or any loose connections that could allow some moisture in to cause a false error. Any help is appreciated. Hopefully someone else has seen or heard of this issue.

 
Sponsored Links
  #2  
Old 11-18-08, 04:44 PM
the_tow_guy's Avatar
Group Moderator
Join Date: Feb 2001
Location: SW Fla USA
Posts: 11,519
Might be helpful to know the actual code # that came up.
 
  #3  
Old 11-18-08, 08:24 PM
Member
Join Date: Sep 2008
Location: Wisconsin
Posts: 82
the problem is that lots of these generic scan tools will some times display false codes or not all codes in vehicle if there are multiple dtcs, I have this problem on saturns before. Using a saturn scan tool(tech 2) or just maybe a little upgrade of one to get the right codes. This is if the code was a cam code and no sensor is two be found, because if there is no cam sensor on the vehicle the computer wouldn't be programed to run a test for it and set a code. Ir this problem happens when it rains maybe check plug wires for arching. or a place where mostuire could be corroiding a connection
 
  #4  
Old 11-20-08, 06:02 AM
Member
Thread Starter
Join Date: Mar 2008
Location: New Jersey
Posts: 17
Question Found the code(s)

There were 2 codes.

The first was P1404 which indicated an EGR valve stuck in the open position.
I removed and cleaned the valve and there wasn't anything noticeably wrong. I would assume that if the valve had an issue, the SES light would remain on all the time.

The second code was P0341. That was the cam sensor position.

Hope these help.

 
  #5  
Old 12-08-08, 08:12 AM
Member
Thread Starter
Join Date: Mar 2008
Location: New Jersey
Posts: 17
Question

Been gone for a while. Posted the codes. Did not get any replies......

 
  #6  
Old 12-08-08, 11:06 AM
the_tow_guy's Avatar
Group Moderator
Join Date: Feb 2001
Location: SW Fla USA
Posts: 11,519
We knew you were away so we waited.

Well I for one am stumped at getting a code for a component the vehicle doesn't have. I suspect it may be time to have it professionally checked with a full-range scanner/analyzer.

The light is still acting as originally described?
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'