Chys Town And Country 3.8 belt keeps coming off

Reply

  #1  
Old 12-20-08, 03:54 AM
Member
Thread Starter
Join Date: Jan 2006
Location: Owen Sound Ontario Canada
Posts: 541
Chys Town And Country 3.8 belt keeps coming off

2000 Chysler Town and Country with 3.8 engine and AWD
Serpentine belt comes off when we go thru a snow drift of 6 inches or more.
Any body know the fix??
 
Sponsored Links
  #2  
Old 12-20-08, 09:01 AM
HotxxxxxxxOKC's Avatar
Banned. Rule And/Or Policy Violation
Join Date: Jul 2006
Location: USA
Posts: 8,044
Hows the belt tentioner? Are you missing a plastic splash shield?
 
  #3  
Old 12-20-08, 12:41 PM
Join Date: Jan 2007
Location: North Central Indiana
Posts: 905
belt

Are you reusing the same belt,,,,,,dont
 
  #4  
Old 12-20-08, 07:58 PM
Member
Thread Starter
Join Date: Jan 2006
Location: Owen Sound Ontario Canada
Posts: 541
Put a new tension pulley on yesterday and it still did it.
Did a bit or research on net and found that some do that.
Today put a shield on the tensioner pulley like I seen on the net and put a new belt on.
Never hit no snow tonight and will see what happens tomorrow. Storm coming in. We will see
 
  #5  
Old 12-20-08, 08:48 PM
Speedwrench's Avatar
Member
Join Date: Apr 2008
Location: Oklahoma
Posts: 1,698
also double check all of your pulley alignments, sometimes since a lot of pulleys are press fit one might simply wear out of alignment and cause them to start throwing belts.

if we're not supposed to eat animals why are they made out of meat?
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'