92 jimmy temp gauge wont work

Reply

  #1  
Old 01-07-09, 08:05 AM
michaeljp86's Avatar
Member
Thread Starter
Join Date: May 2005
Location: USA
Posts: 478
Question 92 jimmy temp gauge wont work

Its a 1992 gmc jimmy 4x4 with auto trans. I had a bad head gasket and just finished getting the engine back together. I fired it up and had the radiator cap off wanting it to warm up and get all the air out of the engine so I could top of the radiator. I had it running for about 20 min and the temp gauge never showed anything. I took it for a little drive and still showed nothing.

There is 2 temp sensors on it, one in the intake manifold next to the thermostat and another on the passenger side cylinder head.

I played with the connection on the sensor on the intake and the gauge showed nothing. I played with the sensor on the cyl head and I had it 1/2 way pulled off the the gauge showed just above 0. I plugged it back in and it stayed showing a little above 0. As soon as I hit the brake and put it in reverse the gauge went back to 0.

It probably ran for over 30min and the sensor on the top of the engine felt hot when I was playing with the sensor so I know the engine was warm.

Anyone have any idea on whats wrong? The sensor on the cylinder head was replaced not to long ago and the gauge always worked fine.
 
Sponsored Links
  #2  
Old 01-07-09, 11:46 PM
Member
Join Date: Dec 2008
Location: Albuquerque New Mexico
Posts: 23
Autozone.com will show you how to test the sensors.
Jeff
 
  #3  
Old 01-08-09, 06:46 AM
michaeljp86's Avatar
Member
Thread Starter
Join Date: May 2005
Location: USA
Posts: 478
I just got it figured out, I took one of those pick tool, looks like a dental pick with a screw driver handle. I got up under the contact in the plug and bent it out a little and the gauge works fine now.
 
  #4  
Old 01-08-09, 02:38 PM
the_tow_guy's Avatar
Group Moderator
Join Date: Feb 2001
Location: SW Fla USA
Posts: 11,541
FWIW, one sensor is for the gauge and the other is for the computer. Playing with the computer input sensor will not affect the temp gauge.
 
  #5  
Old 01-08-09, 02:41 PM
michaeljp86's Avatar
Member
Thread Starter
Join Date: May 2005
Location: USA
Posts: 478
Originally Posted by the_tow_guy View Post
FWIW, one sensor is for the gauge and the other is for the computer. Playing with the computer input sensor will not affect the temp gauge.
The one on the top of the engine is for the computer.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'