2000 sebring tranny

Reply

  #1  
Old 01-17-09, 06:37 PM
Member
Thread Starter
Join Date: Jun 2005
Location: ontario canada
Posts: 381
2000 sebring tranny

car acellerates normal from easing up to speed or flooring the gas..trouble is on slowing down..if letting off on the gas slowly all seems normal..if say , at highway speeds or a little above (say 65 or 70 mph) and let completely off the gas then as the car begins to slow BANG a jerk like the brakes have been hammered on..one maybe two times then all is normal agin...has my tranny given all it can or cn it be coaxed to go another 50,000 miles with some cheap maintenence??
 
Sponsored Links
  #2  
Old 01-17-09, 07:06 PM
Speedwrench's Avatar
Member
Join Date: Apr 2008
Location: Oklahoma
Posts: 1,698
unfortunatly you will need to take it into a trans shop for some trouble shooting, if i remember correctly it has no governor and the trans is electronic for the valvebody.

murphy was a optimist
 
  #3  
Old 01-17-09, 07:35 PM
HotxxxxxxxOKC's Avatar
Banned. Rule And/Or Policy Violation
Join Date: Jul 2006
Location: USA
Posts: 8,044
I had the same type issue with my wife 01 Stratus. That car is long gone and never got it fixxed.
 

Last edited by the_tow_guy; 01-19-09 at 12:30 PM. Reason: He knows why.
  #4  
Old 01-17-09, 08:22 PM
Member
Thread Starter
Join Date: Jun 2005
Location: ontario canada
Posts: 381
thanks for the info..i guess i will ask my chrysler dealer if they can look at it or tell me where to go for some honest trouble shooting or testing
 
  #5  
Old 01-19-09, 10:20 AM
diyplank's Avatar
Member
Join Date: Feb 2006
Location: Williamsport
Posts: 714
I had an 01 sebring and I liked the car. Last spring I started it up, put it in drive, and rpm went shooting up. Put it in reverse and samething, then back into drive and it finally worked. That weekend I changed my transmission fluid and filter and gasket and it didn't work. It did this about 4 more times through april and I went and traded it in for new dodge hemi! I wasn't even going to begin to take it aamco or any other tranny place. I have had bad luck w/ trann. in the past and didn't wanna deal w/ it again. Good Luck
 
  #6  
Old 01-19-09, 12:31 PM
the_tow_guy's Avatar
Group Moderator
Join Date: Feb 2001
Location: SW Fla USA
Posts: 11,574
If you have a regular mechanic, ask him; he'll know who the best guys are. I'm partial to good independent tranny shops myself.
 
  #7  
Old 01-19-09, 02:05 PM
Member
Thread Starter
Join Date: Jun 2005
Location: ontario canada
Posts: 381
My son informed me he topped up the tranny for his mother and used the transmission oil i had on the shelf (dot 3) for my old truck.

My service guy tells me i need to use ONLY Mopar 4 so he recomended I change the filter and the oil as this is about the cheapest thing to try as I can do this myself

If this doesn't work then I shall have think about fixing or dealing...i have found in the past, with my luck once the fixing starts it never ends.
thanks everyone for your input
 
  #8  
Old 01-27-09, 04:44 PM
Member
Thread Starter
Join Date: Jun 2005
Location: ontario canada
Posts: 381
just to let everyone know..i changed the filter and oil in thetranny..no better..took it to the dealer and they said they could re-flash the transmission module for about 100 bucks and they thought that had a good chance at fixong it but not 100 percent sure..well hell i thought that is a lot but in transmission dollars maybe not too much so i took the chance....she runs like new!

maybe someone else can benifit from this...thanks for all the replies
 
  #9  
Old 01-27-09, 05:51 PM
HotxxxxxxxOKC's Avatar
Banned. Rule And/Or Policy Violation
Join Date: Jul 2006
Location: USA
Posts: 8,044
Thanks for the follow up Billie!

Ya know, I read in my Alldata manual that I could have gotten the module reflashed, but I got rid of the thing before I could do it.

$100 is alot better then $2.5k
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes