Help Please


  #1  
Old 03-01-09, 08:20 AM
A
Member
Thread Starter
Join Date: Mar 2009
Posts: 3
Upvotes: 0
Received 0 Upvotes on 0 Posts
Help Please

i have a 97 cavalier i was driving down the road when i noticed the gas pedal had stopped. i pulled to the side to notice the car had died. i tried to restart and it would start then cut out a few seconds later or when i shifted into drive. the lights would still work and the radio was trying to turn on but it wouldnt after a few attempts to start it wouldnt start at all just made a clicking noise. then a man stopped and gave me a boost and it would start and die a few seconds later? is it the battery ? alternator?
 
  #2  
Old 03-01-09, 09:03 AM
the_tow_guy's Avatar
Group Moderator
Join Date: Feb 2001
Location: SW Fla USA
Posts: 12,309
Received 266 Upvotes on 217 Posts
Alternator would be the prime suspect.
 
  #3  
Old 03-01-09, 10:03 AM
A
Member
Thread Starter
Join Date: Mar 2009
Posts: 3
Upvotes: 0
Received 0 Upvotes on 0 Posts
thanks ill get someone to check it out for me !!
 
  #4  
Old 03-01-09, 10:57 AM
J
Member
Join Date: Dec 2008
Location: Albuquerque New Mexico
Posts: 23
Upvotes: 0
Received 0 Upvotes on 0 Posts
It probably is the alt., when it died did it feel like it ran out of gas? Or just shut off?
How long did you keep trying to start it before the battery went dead?
When the guy jumped it, did it stay running while the jumper cables were hooked up? Or was it struggling to stay running?

It might be a fuel filter is dirty and it's starved for gas.

Best thing to do is charge your battery up, and start it, see if it stays running for 5 minutes. It will run on just the battery power for a that long.

If it spudders and dies when you start it (repeatedly) check and see if it's getting gas.
With the great quality of gas now a days, fuel filters need to be changed at least every other oil change.

If it does stay running take it to Autozone and they'll check the charging system for free.
Jeff
 
  #5  
Old 03-02-09, 09:46 AM
A
Member
Thread Starter
Join Date: Mar 2009
Posts: 3
Upvotes: 0
Received 0 Upvotes on 0 Posts
has to be something with the fuel because i got it started but when i put into drive and gave it gas she shut off
 
  #6  
Old 03-02-09, 10:08 AM
J
Member
Join Date: Dec 2008
Location: Albuquerque New Mexico
Posts: 23
Upvotes: 0
Received 0 Upvotes on 0 Posts
I'd start with the fuel filter.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description: