95 Buick LeSabre Blower Fan kept running until it drained my battery

Reply

  #1  
Old 04-03-09, 11:18 AM
Member
Thread Starter
Join Date: Apr 2009
Location: Tennessee
Posts: 1
Question 95 Buick LeSabre Blower Fan kept running until it drained my battery

Hi, Sure hope some good person out there can help. After returning home my 95 Buick LeSabre's blower motor (for heating and cooling inside of car) didn't shut off after I turned off the car and pulled out the keys. Consequently, if totally ran my battery down. After doing some research I discovered I could not find the ac relay. Their was no chart in the maxifuse and relay center box under the hood. Have no idea which relay is for the sensor because they all look the same. I was able to jump the car off and not drain it again by removing the ac fuse under the hood. Does anyone know where or which relay is the right one. Times are tough right now really cant afford to take it to the shop. Also wondering if the relay is the problem. Please help. Will be greatly appreciated!
 
Sponsored Links
  #2  
Old 04-03-09, 07:52 PM
Member
Join Date: Jun 2008
Location: Eastern Georgia
Posts: 486
If your car has automatic climate control the fan speed controller is most likely bad.Not sure where it is located on your 95 but it should be square about 3/4 inch thick and have several wires plugged into it. It also has an area with a finned aluminum heat sink. Used to be on the engine compartment side of the firewall somewhere near the center on the older models. Maybe a Haynes manual will tell you where it is at.
 
  #3  
Old 04-05-09, 01:43 PM
Member
Join Date: Jan 2006
Location: Owen Sound Ontario Canada
Posts: 541
Is it fixed?

So did you get it fixed?
I have a 94 Lesabre and a book and I could help try to figure it out but I wont bother if you have it under control.
 
  #4  
Old 11-18-09, 07:16 AM
Member
Join Date: Nov 2009
Location: United States
Posts: 1
Buick Blower

I know its been awhile when you posted your problem, but I have the same trouble with my blower running all the time. Did you fix the problem? if so could you fill me in? The blower runs even when I unplug the relay on the firewall and I know the blower control module is working. If you or anyone could show me a diagram of the fan switch (94 Buick Lesabre) or relays on the inside passenger side of the car.

Thanks in advance.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'