Tie rod? Linkage? 86 cavalier

Reply

  #1  
Old 04-20-09, 05:10 PM
Member
Thread Starter
Join Date: Apr 2009
Location: Nebraska
Posts: 12
Tie rod? Linkage? 86 cavalier

What is this? My right wheel on my cavalier has that hook shaped arm with no bolt on, while the left side is fine. It started screeching at me when I turn to the right today and im emailing back and forth with the mechanic. Im not sure what to call it and my chiltons doesn't have a good pic of it.



Thanks!

CAS
 
Sponsored Links
  #2  
Old 04-20-09, 07:57 PM
Member
Thread Starter
Join Date: Apr 2009
Location: Nebraska
Posts: 12
Better Pics

Here are some actual pics

First, right side wheel, which is fine:


Then left side wheel:


Both pics taken from back to front via the wheelwell. I also noticed that power steering fluid was shooting up through a pin hole in the cap on the reservoir when I turn the steering wheel-do Pwr steering caps have vents? I never noticed before.
 
  #3  
Old 04-21-09, 06:18 PM
Unclediezel's Avatar
Member
Join Date: Dec 2006
Location: Northeastern PA.
Posts: 2,230
That would be a stabilizer link.....

Yes P/s Caps are vented......But they should not "Stream" fluid, unless the reservoir is overfilled, or you turned the wheel with the engine off...Be careful, P/s Fluid is flammable on a hot Exhaust manifold.
 
  #4  
Old 04-21-09, 06:26 PM
Member
Thread Starter
Join Date: Apr 2009
Location: Nebraska
Posts: 12
Thanks! Some more info please?

I took it in this AM to my local mech. and he fixed the sway bar-it still makes a noise like something is rubbing on the cv shaft, maybe? Is that plausible? Its not the engine, and it didnt start until this other bit became uncoupled. It makes it most predominantly when I turn to the right (the side with the bad sway bar, since repaired)

thanks for the info about the PW steering fluid-I probably overfilled it worrying about this other thing.
 
  #5  
Old 04-21-09, 06:34 PM
Unclediezel's Avatar
Member
Join Date: Dec 2006
Location: Northeastern PA.
Posts: 2,230
Exactly....

Your pic of the r/s wheel shows the link ...way to close to CV.....that distance changes when you turn.....

Not to pick on anyone.....But if your mechanic didnt see that, then you need a new Mechanic....
 
  #6  
Old 04-21-09, 07:31 PM
Member
Thread Starter
Join Date: Apr 2009
Location: Nebraska
Posts: 12
Okay...

So im not understanding something then, the swaybar was fixed this afternoon, but I still heard the same noise. Is there something else maybe that he should have done, or adjusted? He didnt drive it, he went off of the pics, so he didn't hear the noise.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes