Camry woes

Reply

  #1  
Old 05-14-09, 11:59 AM
daswede's Avatar
Member
Thread Starter
Join Date: Jul 2003
Location: massachusetts
Posts: 2,194
Camry woes

My son's 2001, 4 cyl., auto. has some running issues that caused the car run rough (miss),and seem to lose power when trying to accelerate. All this happened in just 2 days.

He took it to a garage because of a CEL warning. garage checked it on a computer and said Cat. was bad. He had the Cat changed, and it still runs bad.

He went Back to the garage and they put it on the computer and the code/s came back spark plugs,and/or wires. Of course they wanted to replace these parts,but he said he wanted to check it out some more as he asked why it didn't show up with the Cat test.

He then went to Auto Zone for a scan,and Auto zone came up with 3-6 code possibilities ,which two were plugs and wires. He changed the plugs and problem is still there.

I'm looking for some information on possible causes.

Thanks for any help.
 
Sponsored Links
  #2  
Old 05-14-09, 02:18 PM
HotxxxxxxxOKC's Avatar
Banned. Rule And/Or Policy Violation
Join Date: Jul 2006
Location: USA
Posts: 8,044
Most likely, your bad cat destroyed the O2 sensor(s). What codes were they?
 
  #3  
Old 05-14-09, 02:34 PM
daswede's Avatar
Member
Thread Starter
Join Date: Jul 2003
Location: massachusetts
Posts: 2,194
I'll have ask him.

On a side note,the car being less than 10 yrs. old, and with 101000 mi,do you think he should pursue "good will" help with converter from Toyota?
 
  #4  
Old 05-14-09, 02:51 PM
Gunguy45's Avatar
Super Moderator
Join Date: Dec 2007
Location: USA
Posts: 20,789
I think you may be over the mileage by quite a bit..seems like 80K is the limit isn't it? And without having the old cat for them to possibly cut open.....seems iffy.
 
  #5  
Old 05-14-09, 03:15 PM
the_tow_guy's Avatar
Group Moderator
Join Date: Feb 2001
Location: SW Fla USA
Posts: 11,513
I could be wrong, but it sounds like that garage is maybe depending a little too much on what the scanner is telling them. Beer 4U2

Would be interesting to see what codes are coming up.

FWIW, my wife drives same car; has just shy of 100k miles.
 
  #6  
Old 05-14-09, 03:24 PM
daswede's Avatar
Member
Thread Starter
Join Date: Jul 2003
Location: massachusetts
Posts: 2,194
I thought the mileage limit was 100k and 10 yrs. You are probably right.

Thinking about it more, i don't know why the garage didn't pick up on the rough running along with the Cat. problem.

I'll keep you all posted when i get more answers.
 
Reply


Thread Tools
Search this Thread
Display Modes
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 09:00 PM.