Mitsubishi Eclipse Wiper Issue

Reply

  #1  
Old 06-10-09, 07:29 PM
Member
Thread Starter
Join Date: Jan 2007
Location: NJ
Posts: 453
Mitsubishi Eclipse Wiper Issue

I have a 2001 Mitsubishi Eclipse where the wipers seem to be malfunctioning. When you pull the handle down one to the intermittent level the wipers stop randomly at different times. In other words, it does not stop intermittently when the wipers reach the bottom. Sometimes it stops mid-way or even when it is close to 90 degrees.

When you pull the handle back up to the off level, the wipers keep going and does not stop at all. You have to turn off the engine to completely stop the wipers. What's wrong and how do you fix this?

Could it be the wiper relay? If so, where is that located?
 

Last edited by MikeyBoy; 06-10-09 at 08:00 PM.
Sponsored Links
  #2  
Old 01-13-10, 12:23 AM
Member
Join Date: Oct 2008
Location: York, PA
Posts: 6
I don't know if this is too late for you, but it sounds like your wipe switch is broken. This same thing happened to my buddies 98 Eclipse. I know they are a different model year and type, but the switches are pretty much the same. Remove the steering column cover and remove the switch, then replace with a new one from the auto parts store or parts yard.
 
Reply


Thread Tools
Search this Thread
Display Modes
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 05:48 AM.