Geo won't start. Speed Sensor???

Reply

  #1  
Old 06-15-09, 07:11 PM
Member
Thread Starter
Join Date: Dec 2008
Location: Alabama
Posts: 73
Geo won't start. Speed Sensor???

I have a 96 Geo Prizim that went dead on me while I was driving down the road. I had just replaced the water pump and was having problems with the automatic transmission shifting gears. If I let off the gas and ease back on it it would shift. On my way to AutoZone my car just went dead. The engine turns over but it will not hit. My dad had a ford explorer die on him at a red light and it did the same thing. He said it would turn over but it would not crank. He had it towed to a dealer and they had to replace his speed sensor. The people at AutoZone do not think that it is the speed sensor. I had them run a diagnostic on it and it came back without any error codes. If anyone has any ideas what my problem might be please let me know. Thanks.
 
Sponsored Links
  #2  
Old 06-16-09, 04:41 AM
the_tow_guy's Avatar
Group Moderator
Join Date: Feb 2001
Location: SW Fla USA
Posts: 11,539
I've never heard of a speed sensor creating a no-run situation. You need to determine whether it's a spark issue or fuel problem. First off I would check for a broken timing belt; remove distributor cap and see if the rotor turns when you crank the engine. Next check for spark; pull a plug wire and hold near ground (carefully!) and see if you get a spark when someone turns the key. Next up would be fuel pressure check; going to need a gauge for that, although you can do a basic check to see if the pump is even running by listening at the fuel filler when the key is first truned on. Should get an audible humm for several seconds. Side note, generally "cranking" and "turning over" are used to describe the same situation, i.e. the engine rotates when the key is turned. To describe your condition I would say that it cranks but doesn't fire (or run).
 
  #3  
Old 06-16-09, 09:37 AM
Member
Thread Starter
Join Date: Dec 2008
Location: Alabama
Posts: 73
Thanks, Tow Guy. I will give that a try this afternoon.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'