warming up issues

Reply

  #1  
Old 07-03-09, 08:33 PM
Member
Thread Starter
Join Date: Apr 2009
Location: Hammond, Louisiana
Posts: 94
warming up issues

Hey all, i got a 1990 ford f250 5.0. anyway, recently i noticed that when starting it starts great but the idle is kinda wierd warming up. when i start it itl get a real low idle like it wants to die then go up for a second, then go back down for a second or two then return to normal after its heated up. also if i put it in reverse or drive immidiately after starting it it will sometimes die.

any thoughts?
 
Sponsored Links
  #2  
Old 07-04-09, 08:54 PM
Unclediezel's Avatar
Member
Join Date: Dec 2006
Location: Northeastern PA.
Posts: 2,230
Late 80's and early 90's Ford products had a horrible reputation for the design of the EGR system.....

Going from memory, after 20 years, Your egr has a green vacuum tube to it from an EVR solenoid (Electronic Vacuum regulator). On top of the EVR is a Plastic "CAP" with a "Sponge " filter under it. Pry the cap off, remove the filter, replace the cap and drive the truck....If your symptoms are corrected, replace EVR, remove the EGR valve , clean the passages with carb cleaner, (Brake Kleen, Throttle body cleaner, air intake cleaner, Any flavor of Acetone based solvent you prefer) and reinstall.
 
  #3  
Old 07-05-09, 06:32 PM
Member
Thread Starter
Join Date: Apr 2009
Location: Hammond, Louisiana
Posts: 94
alright ima try that tuesday. i was thinking it could possibly be a dirty throttle body or injectors. im cleaning both of them tues also along with alittle tune up. thx for the tip
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'