2002 Saturn Vue Trans/electrical problems???

Reply

  #1  
Old 08-16-09, 02:12 PM
Member
Thread Starter
Join Date: Nov 2008
Location: USA
Posts: 4
Exclamation 2002 Saturn Vue Trans/electrical problems???

I have a 6 cylinder automatic were the transition goes into high gear while driving and should be in a lower gear. If you stop the car, turn it off then back on it goes right back into the normal driving mode. The service engine light does come on but I have not been able to get it to a mechanic before the codes clear. If you do not start the car every few days the battery goes dead and the codes clear. We replaced the battery thinking that there may have been a bad cell but the new one will also die if the car is not started every couple of days. Does anyone have any ideas as to what could be wrong?
 
Sponsored Links
  #2  
Old 08-16-09, 05:55 PM
HotxxxxxxxOKC's Avatar
Banned. Rule And/Or Policy Violation
Join Date: Jul 2006
Location: USA
Posts: 8,044
Just because the service light is not on, does not mean codes are being stored. I'm having trouble trying to figure out what your problem is. What do you mean it should be in a different gear? If your new battery is dead as well, then your alternator is not charging it, or something is drawing the battery dead when off.
 
  #3  
Old 08-17-09, 03:10 AM
Member
Thread Starter
Join Date: Nov 2008
Location: USA
Posts: 4
Originally Posted by HotinOKC View Post
Just because the service light is not on, does not mean codes are being stored. I'm having trouble trying to figure out what your problem is. What do you mean it should be in a different gear? If your new battery is dead as well, then your alternator is not charging it, or something is drawing the battery dead when off.
When driving in a lower gear it will just go into the highest gear feeling like it went into neutral (car does not go anywhere when this happens). The only way to get it back into the lower gear to drive again is to turn the car off then back on (sounds like this resets something).
When the battary dies the codes are clearing based on what we were told from the shop we took it to. We tried taking it there after charging the battery and they were not reading any codes. Thet suggested that we drive it until the lights come on and try and get it back in before the battery dies. It sounds like something linked to the trans problem is draining the battery because the alternator will keep the battery charged as long as you drive the car. The battery seems to die shortly after the codes appear. Does this help any?
 
  #4  
Old 08-17-09, 04:02 PM
HotxxxxxxxOKC's Avatar
Banned. Rule And/Or Policy Violation
Join Date: Jul 2006
Location: USA
Posts: 8,044
I don't think anything in the transmission could cause the battery to drain. Also, if you are not getting the correct voltage (alternator), you will have issues like you have because there is not enough juice to the computer modules.
 
  #5  
Old 08-17-09, 05:01 PM
Member
Join Date: Sep 2008
Location: Wisconsin
Posts: 82
if the check engine light is going on the pcm is probly detecting a condition/fault in the trans, if it is a condition that the pcm thinks could cause damage it will put the trans in limp mode defaulting the trans in second or third gear all the time. as for the dead battery u should check your alt output or for parasitc drain
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes