1993 Ford Ranger Problem

Reply

  #1  
Old 08-18-09, 08:11 PM
Member
Thread Starter
Join Date: Jun 2005
Posts: 21
Smile 1993 Ford Ranger Problem

This is a continuation of 8/15/09. Well, things have changed now. Yesterday was the first day I used the fuel pressure guage. Yesterday, sometimes the pressure would go up to 10 PSI when I first turned on the key, not running, but the truck would start every time. Right now it's very different. I did what you asked me to do. When I turn the key on this time, the pressure shoots right up to 40PSI. The fuel pump is not shutting off this time. It just keeps running and when I try to start the engine, it doesn't start. The engine just keeps turning. It almost sounds like it is not getting any fuel. After literally minutes the fuel pump finally stops the fuel pressure drops to 31-32 PSI and the truck starts with no problem. Other ideas? Thanks!
 
Sponsored Links
  #2  
Old 08-19-09, 04:16 AM
Unclediezel's Avatar
Member
Join Date: Dec 2006
Location: Northeastern PA.
Posts: 2,230
Which engine is this????

30 psi is sounding a bit low.....
 
  #3  
Old 08-19-09, 03:43 PM
Member
Thread Starter
Join Date: Jun 2005
Posts: 21
1993 Ford Ranger

The engine is a 6 cylinder 4.0. It just seems to have a hard time starting. The 40 PSI goes to 31-32 PSI as soon as it starts. I disconnected the vacuum line to the regulator and the pressure goes up. Could it be getting too much fuel?? Thanks!
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'