Gmc yukon vent solenoid

Reply

  #1  
Old 12-17-09, 02:52 PM
Stick1's Avatar
Member
Thread Starter
Join Date: Dec 2009
Location: Ma.
Posts: 22
Gmc yukon vent solenoid

Evap code 466. replaced vent solenoid. reset to clear code.
drove car no check engine light and now was able to fill tank.
Shut off engine for around 10 min. Started car and light came back on . Vent code. What else could be causing this problem.
On this model the solenoid is mounted directly to vent box . Car was built late 2003.
 
Sponsored Links
  #2  
Old 12-19-09, 12:40 AM
Join Date: Jul 2009
Location: Washington State
Posts: 312
Believe it or not a bad /loose fuel cap can cause that problem and evap code reset maybe 5 a week in my shop and replace maybe 3 or 4 caps a month. since it came back after filling the tank that is the direction I'd look.
 
  #3  
Old 12-22-09, 01:33 PM
Stick1's Avatar
Member
Thread Starter
Join Date: Dec 2009
Location: Ma.
Posts: 22
Originally Posted by Maniac Mechanic View Post
Believe it or not a bad /loose fuel cap can cause that problem and evap code reset maybe 5 a week in my shop and replace maybe 3 or 4 caps a month. since it came back after filling the tank that is the direction I'd look.
Thanks I will try that next.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes