91 lumina engine noisy lifters good oil pressure

Reply

  #1  
Old 03-03-10, 04:32 PM
Member
Thread Starter
Join Date: Mar 2010
Posts: 3
91 lumina engine noisy lifters good oil pressure

I have a 91 lumina 3.1 297,000 miles ran very good until the engine started rattling sounds like noisy lifters no oil on push rods,has good oil pressure. It idles good but misses above 3,500 RPMs like a rev limiter. Changed oil filter add sea foam,wd40 didn't help.
 
Sponsored Links
  #2  
Old 03-03-10, 06:43 PM
Banned. Rule And/Or Policy Violation
Join Date: May 2007
Location: Wisconsin
Posts: 8,629
I think at 300,000 miles, gasoline engines have a tendency to be going south by then. Could be due to any one component or many up in the valvetrain. If say the outer hardened protective layer of the camshaft were gone and you had cam wear, that would cause one or several valves to not lift as much anymore and act like a rev limiter. However, so could any slop between parts up there.

Motor honey, by various names, might help some. Might be hard on the engine though if it still gets real cold at night where you are.
 
  #3  
Old 03-05-10, 01:12 AM
automd's Avatar
Member
Join Date: Oct 2009
Location: Indiana, USA
Posts: 38
Lifters are misdiagnosed commonly as the source of many noises when in reality they are quite trouble free. Dirt contamination on a sludged engine is the number one cause of true lifter noises, low oil pressure is number two but since you have good oil pressure, you can scrap it out.
 
  #4  
Old 03-05-10, 01:45 AM
Member
Join Date: Dec 2002
Location: Pittsburgh, PA
Posts: 551
With 300K on it I think you got your moneys worth...warranty is up, good job..LOL! Maybe try some Marvel Mystery Oil, I have used it in the past to clear out sludge. Motor Honey is thick like honey, MMO is thin like a solvent. What the heck, at 300K what do you have to lose?
 
  #5  
Old 03-05-10, 03:36 PM
Member
Thread Starter
Join Date: Mar 2010
Posts: 3
Originally Posted by drgansen View Post
I have a 91 lumina 3.1 297,000 miles ran very good until the engine started rattling sounds like noisy lifters no oil on push rods,has good oil pressure. It idles good but misses above 3,500 RPMs like a rev limiter. Changed oil filter add sea foam,wd40 didn't help.
This car ran like it was new last week, all lifters or diesel noise started all of a sudden, still has 60PSI oil presssure. Could a cam bearing have spun stopping oil flow, I would think it should be broke in by now!
 
  #6  
Old 03-05-10, 06:49 PM
Banned. Rule And/Or Policy Violation
Join Date: May 2007
Location: Wisconsin
Posts: 8,629
Maybe weak valvesprings. Then they start to float above 3500 rpm.
 
  #7  
Old 03-22-10, 03:38 PM
Member
Thread Starter
Join Date: Mar 2010
Posts: 3
The cam was two teeth out if time, I put in a new timing chain run good agian.

Thanks for your help
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'