2004 CVPI - Pinging and Hesitation

Reply

  #1  
Old 05-01-10, 10:23 PM
Codyy's Avatar
Member
Thread Starter
Join Date: May 2006
Location: Canada
Posts: 477
2004 CVPI - Pinging and Hesitation

Hey guys, I'm having a troubling pinging and hesitation problem and I need some more ideas. I've posted on another forum before and haven't had luck so far so maybe someone here has further insight!

The vehicle in question is a 2004 Ford Crown Victoria Police Interceptor.

I've been trying to take care of my pinging/hesitation problem for quite some time now. Basically, the car pings under 1/2 to 3/4 throttle and I also get hesitation. The hesitation occurs when I am already moving and decide to punch it. This is my previous description of it complete with a video (please watch to hear it):


Video here: YouTube - Driveability Issue - 2004 Crown Victoria PI

Basically what's happening (as evidenced by the video) is that I punch the accelerator and the car starts to move - you can hear that in the video. But then, around 0:05 seconds in the video, you can hear the tone change and the engine starts to pull harder. Sometimes, when that hesitation occurs for that split second, it is violent enough to shake the passengers - the engine picks up all of a sudden.


The engine doesn't ping or hesitate IF I accelerate WOT from a dead stop. From it hesitates like crazy like in the video if I punch it while rolling already, and like I said, pinging under 1/2 to 3/4 throttle.

This is what I have done in an attempt to remedy the problem:

- new air filter
- good fluid levels across the board
- new MC spark plugs w/ correct gap
- multiple Seafoam treatments
- coolant flush
- new thermostat
- cleaned MAF sensor
- replaced MAF sensor
- replaced TPS sensor
- new fuel filter
- reset PCM
- Ford analysis with ids system (long term and short term fuel trim strategies are fine, no codes, no issues found at all)

Also note that with either the MAF or the TPS unplugged pinging GOES AWAY. BUT, hesitation remains.

I've decided that I will attempt repair one more time and if not, move on to a different Panther.

So, if this was your car sitting outside, what would you do next? Please be as descriptive as possible, I've dumped a lot of time and effort into this to try and fix it with depressing results. Hopefully someone with a good grasp on the workings of all these sensors/ECU and PCM function can help me get this fixed!
 
Sponsored Links
  #2  
Old 05-02-10, 06:00 AM
hopkinsr2's Avatar
Member
Join Date: Feb 2005
Location: canada
Posts: 1,563
For some reason I'm thinking there was a reflash for the PCM for pinging issues... Not sure about the hesitation... What is the fuel pressure when this happens??? Roger
 
  #3  
Old 05-02-10, 06:12 AM
the_tow_guy's Avatar
Group Moderator
Join Date: Feb 2001
Location: SW Fla USA
Posts: 11,571
EGR system checked? Probably not it as you should get a code/light.
 
  #4  
Old 05-02-10, 07:02 AM
Member
Join Date: Feb 2010
Location: U.S.A.
Posts: 248
Do you have the same symptoms using "premium fuel"?
 
  #5  
Old 05-02-10, 08:28 AM
Member
Join Date: Oct 2008
Posts: 1,312
Well I would very carefully check out the fuel system...

The "electronic" fuel system.

And the "mechanical" fuel system.

The following electronic sensors give input to the engine computer, and based on this information, the computer decides how much fuel to mix. (in general for all vehicles - your vehicle may have different sensors or different names).

Coolant temperature sensor - Lean/rich
Oxygen sensor - Lean/rich
Atmospheric (barometric) pressure - Lean/rich
Manifold Absolute Pressure - More fuel
(Mass Air Flow Sensor)
Throttle Position Sensor - More fuel

So each of these sensors should be tested to be sure they are giving the engine computer the correct "information". Testing instructions for these would be in a factory service manual set of books.

Then if the "electronic" part of the system is working ok and it is telling the fuel system to add the proper amount of fuel, then next I would check the mechanical part of the fuel system.

Is the fuel system *able* to deliver as much fuel as is needed?

Following is a *full* fuel system check. Note the part about testing for "volume" of fuel as well as fuel pressure...
Fuel Injection Service, Not Just Cleaning

If that all checks out ok, then the following electronic sensors have to do with timing...

Crankshaft position sensor
Engine speed (RPM)
Engine load (manifold pressure or vacuum)
Atmospheric (barometric) pressure
Engine coolant temperature
Intake air temperature (retards timing when hot)

(Again for all vehicles in general, the names of these things can be different for different vehicles.)

And was there anything you did (like new spark plugs) and then this problem suddenly started happening? If yes, then be sure that part or whatever was installed/replaced is factory specification and/or working properly.

The *real* clue is disconnecting the MAF and TPS and then part of the problem goes away. If we knew *exactly* how the engine computer worked, we would know what this is doing and that would give us a BIG clue! However they keep the internal workings of engine computers secret, so I'm not sure what disconnecting this would do.

-Make the computer think there was less/more air or that the throttle was open/closed more/less?

-Or ignore the inputs entirely as there is no electrical connection and base the adjustments on other information? (Limp home mode.)

And this is a pet peeve of mine. If they want someone to fix something, they should give you all the technical information as to how it works. If you fully understand how something works, then you can understand exactly what is happening (or can read about it somewhere like for a situation like yours).
 
  #6  
Old 05-02-10, 09:26 AM
Codyy's Avatar
Member
Thread Starter
Join Date: May 2006
Location: Canada
Posts: 477
First of all, thanks for the responses!

Originally Posted by hopkinsr2 View Post
For some reason I'm thinking there was a reflash for the PCM for pinging issues... Not sure about the hesitation... What is the fuel pressure when this happens??? Roger
Ford was supposed to have checked for PCM upgrades when I took it there to be hooked up to there computers. They said fuel trim, long term and short term, was fine, amongst other things.

Apparently for the 2004 MY I can't use a traditional fuel pressure gauge on a Schroeder valve. I've been told I need a scanning tool, so that hasn't been done yet.

Originally Posted by the_tow_guy View Post
EGR system checked? Probably not it as you should get a code/light.
Haven't been able to find any specific way to check it, so I would like to but I'm not certain. I don't have a code/light though, but then again who knows?

Originally Posted by Giles View Post
Do you have the same symptoms using "premium fuel"?
Using premium fuel, the pinging DOES go away. The hesitation, like in the video, basically remains.

However, my car is designed for 87 and thus should run fine on 87 since it has not been tuned. So I don't like to use the 91 to mask the problem since I'll just be damaging my converters sending unburned fuel away.

Originally Posted by Bill190 View Post
Well I would very carefully check out the fuel system...

The "electronic" fuel system.

And the "mechanical" fuel system.

The following electronic sensors give input to the engine computer, and based on this information, the computer decides how much fuel to mix. (in general for all vehicles - your vehicle may have different sensors or different names).

Coolant temperature sensor - Lean/rich
Oxygen sensor - Lean/rich
Atmospheric (barometric) pressure - Lean/rich
Manifold Absolute Pressure - More fuel
(Mass Air Flow Sensor)
Throttle Position Sensor - More fuel

So each of these sensors should be tested to be sure they are giving the engine computer the correct "information". Testing instructions for these would be in a factory service manual set of books.

Then if the "electronic" part of the system is working ok and it is telling the fuel system to add the proper amount of fuel, then next I would check the mechanical part of the fuel system.

Is the fuel system *able* to deliver as much fuel as is needed?

Following is a *full* fuel system check. Note the part about testing for "volume" of fuel as well as fuel pressure...
Fuel Injection Service, Not Just Cleaning

If that all checks out ok, then the following electronic sensors have to do with timing...

Crankshaft position sensor
Engine speed (RPM)
Engine load (manifold pressure or vacuum)
Atmospheric (barometric) pressure
Engine coolant temperature
Intake air temperature (retards timing when hot)

(Again for all vehicles in general, the names of these things can be different for different vehicles.)

And was there anything you did (like new spark plugs) and then this problem suddenly started happening? If yes, then be sure that part or whatever was installed/replaced is factory specification and/or working properly.

The *real* clue is disconnecting the MAF and TPS and then part of the problem goes away. If we knew *exactly* how the engine computer worked, we would know what this is doing and that would give us a BIG clue! However they keep the internal workings of engine computers secret, so I'm not sure what disconnecting this would do.

-Make the computer think there was less/more air or that the throttle was open/closed more/less?

-Or ignore the inputs entirely as there is no electrical connection and base the adjustments on other information? (Limp home mode.)

And this is a pet peeve of mine. If they want someone to fix something, they should give you all the technical information as to how it works. If you fully understand how something works, then you can understand exactly what is happening (or can read about it somewhere like for a situation like yours).
Interesting, thank you for this.

Looks like I am going to have to try and get a scan tool or something and check fuel pressure at different times and intervals.

Regarding the unplugging of TPS/MAF and whatnot, I was trying to figure that one out too. Some people suggested that when unplugged the computer used the richer fuel tables and therefore my problem disappeared. Others, however, said that if I unplugged it and the problem disappeared that meant the sensor was bad, and to replace it (and as I wrote hear, that didn't quite turn out that way!)

I haven't done anything to the car that seemed to "spark" the beginning of pinging/hesitation. It may have been the car around when I first got the car... but back then I didn't know what pinging was and I guess I didn't drive it hard enough to feel it hesitate/buck like that.


An overall question for everyone - do you think the hesitation and pinging are related both to the engine, or that it is just a coincidence that they are happening at the same time? Some people suggested that the hesitation was related to the transmission (torque converter, or a very slow downshift) but again, it's all guesses!

Many thanks again!
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes