What could cause intermittent spray from a throttle body fuel injector?

Reply

  #1  
Old 05-21-10, 10:06 PM
Member
Thread Starter
Join Date: Jan 2010
Location: California
Posts: 7
What could cause intermittent spray from a throttle body fuel injector?

It is not the injector itself.
We replaced it when we found we had fuel delivered to it but no spray from it.
Once the injector was replaced the car fired up but ran roughly and now we have no injector spray yet again.
The car does not have a injector relay it is driven directly by the ECM. Could the ECM cause the intermittent lack of spray or shoud we hunt for a loose connection??

The fuel filter is good and clear.
Injector is new.
Fuel is being delivered.
Sometime it sprays sometimes it doesn't
It seems you can get it to run at high rpms and stay there but falls on it face (most of the time)
in the lower RPM's
again this car has no fuel injector relay it is drivien directly off of the ECM

Should we take the ECM out of the possibiltities being as it is intermittent or is this possibly the ECM?

Any help would be appreciated.
Thanks in advance.
 
Sponsored Links
  #2  
Old 05-22-10, 03:12 AM
mickblock's Avatar
Member
Join Date: Feb 2009
Location: Calumet Township, Indiana
Posts: 616
So how are you making the determination that this injector is spraying intermittently?
The ECM is still informed by other sensors on how to fire that injector.
But it sounds like it could be a wiring issue also.
Time to make use of the OBD so you can narrow this down!

What are you drivin and what's the engine? That info helps out the experienced mechanics on this forum.
 
  #3  
Old 05-22-10, 10:51 AM
Member
Thread Starter
Join Date: Jan 2010
Location: California
Posts: 7
Originally Posted by mickblock View Post
So how are you making the determination that this injector is spraying intermittently?
The ECM is still informed by other sensors on how to fire that injector.
But it sounds like it could be a wiring issue also.
Time to make use of the OBD so you can narrow this down!

What are you drivin and what's the engine? That info helps out the experienced mechanics on this forum.

Its a 1984 oldmobile omega with a 4 cyl. The reason we knew it had interittent spraying issues and replaced the injector is because sometime it wont start at all and when it wont there is no fuel from the injector but there is fuel to the injector well.

Thanks again.
 
  #4  
Old 05-22-10, 03:36 PM
Unclediezel's Avatar
Member
Join Date: Dec 2006
Location: Northeastern PA.
Posts: 2,230
.....I remember this one

Look closely at the wiring harness to the injector, where it passes thru the rubber grommet at the edge of the T-Body. You may very well find that it has been pinched at some point in time by the air cleaner.

If that checks out ok, lift the coil wire off of the ignition coil "Slightly", and start the car. Have an assistant check for Injector Pulse or spray, while a second assistant watches the spark.

"Did you lose spark when the injector stopped spraying"????????

ALL----- and I mean .....ALL ---electrical equipment requires two basic things to operate, Positive , and Ground!!!!. Now, while you are correct in "Driven by ECM", the ECM only does the "Ground". There is still a Positive Supply necessary from outside ECM that Could concievably be from a relay.(Although, mid 80's GM.....I doubt It, More likely a line fron Ignition switch , Via the fuse block) You will need a 12v "Test Lamp", with the clip on (-) battery, and probe the "Hot " wire with the ignition key turned on. (If I Recall, They were Red and Blue....so test the RED one). Post back.
 
  #5  
Old 05-22-10, 03:39 PM
Unclediezel's Avatar
Member
Join Date: Dec 2006
Location: Northeastern PA.
Posts: 2,230
ooops.....

One More Thing... Check the Motor oil. Low oil pressure will Shut down the fuel pump and possibly Injector power to avoid "Catastrophic" failure in the event of oil loss.
 
Reply


Thread Tools
Search this Thread
Display Modes
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 03:07 AM.