Turn Signal Problem


  #1  
Old 06-13-10, 12:22 PM
H
Member
Thread Starter
Join Date: May 2007
Location: Midwest
Posts: 61
Upvotes: 0
Received 0 Upvotes on 0 Posts
Question Turn Signal Problem

I have a problem with the right turn signals on my 2000 Toyota Avalon. Here is the problem:

Neither the front or rear turn signal on the right side of the car flash when the right turn signal is turned on.

The indicator light in the dash does not light up when I turn the right turn signal on, however, it makes a very rapid clicking sound.

The right side turn signals and the indicator light on the dashboard both work OK when I turn on the emergency 4 way flashers.

The left side turn lights work normal in all cases with normal clicking or flashing speed.

Could some please help me with this issue?

Thank you in advance with any help you can give me with trouble shooting this issue!!
 
  #2  
Old 06-13-10, 01:02 PM
B
Member
Join Date: Jul 2006
Location: Near Philly
Posts: 553
Upvotes: 0
Received 0 Upvotes on 0 Posts
Just to confirm, both front and rear right side turn signal lights blink when 4-ways are used but neither using turn signal? Usually when they blink fast there is a bulb burnt out on that side.
 
  #3  
Old 06-13-10, 01:07 PM
H
Member
Thread Starter
Join Date: May 2007
Location: Midwest
Posts: 61
Upvotes: 0
Received 0 Upvotes on 0 Posts
Yes, that is correct. Both work when turning on the 4 way emergency lights, including the light on the dash board which also lights up.

Neither the front or rear (or dash board arrow) signal work when turning on the right turn signal. Only a rapid clicking sound but no lights anywhere.

Also, the 4 way flasher flashes at normal speed.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description: