1996 mustang air conditioner prob

Reply

  #1  
Old 06-21-10, 01:07 AM
Member
Thread Starter
Join Date: Jun 2010
Location: united states
Posts: 1
1996 mustang air conditioner prob

I have a 1996 ford muxtang , srs , v-6 , has 140,000 miles . I recently drove it on a 200 mile trip . used the air for the first time this year . It worked super , then about 150 miles into the trip m seemed to just go warm . So , I shut it off , and when I arrived , noticed a clicking , squealing noise . Under the hood I noticed kind of a reddish dusting , aeound the unit , spreading out , and oily to the touch , and the front of the air cond. unit appears to be kind of a loose bearing or something .
Any help or advice would be grately appreciated !! ?
 

Last edited by joepaintsit101; 06-21-10 at 01:29 AM.
Sponsored Links
  #2  
Old 06-21-10, 04:27 AM
the_tow_guy's Avatar
Group Moderator
Join Date: Feb 2001
Location: SW Fla USA
Posts: 11,517
Sounds like the compressor is toast. Probably need to get it checked at a good ac shop. I'm guessing the reddish dust is just from rust buildup on the compressor clutch geting loose the first time you engaged the ac. The oiliness is going to be a leak somewhere and from the description I would assume the front seal/bearing.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'