rubbing and CV joint type sound..

Reply

  #1  
Old 08-17-10, 04:11 PM
NEsportsfan's Avatar
Banned. Rule And/Or Policy Violation
Thread Starter
Join Date: Mar 2010
Location: Insanity
Posts: 361
rubbing and CV joint type sound..

This morning my '95 Crown Vic started to make a rubbing sound when I first turned the wheel with the car just after shifitng into DRIVE. It also makes a sound upon turning like a CV joint going south. I did put in some P/S fluid today and it is still making those noises. Any ideas what it can be since I cannot see how it can be rubbing and as far as I know RWD cars do not use CV joints although with this car I wouldn't be entireely surprised if it did. Thank you much for any input. BTW it has 149,500k on it.
 
Sponsored Links
  #2  
Old 08-17-10, 07:10 PM
ASE MASTER's Avatar
Banned. Rule And/Or Policy Violation
Join Date: Aug 2010
Location: USA
Posts: 560
Rule out:

Small stones or rocks stuck in the threads of the tires.
Issues with ball joints or tie rod ends.
Bent, distorted or worn front suspension parts.
 
  #3  
Old 08-19-10, 01:54 PM
NEsportsfan's Avatar
Banned. Rule And/Or Policy Violation
Thread Starter
Join Date: Mar 2010
Location: Insanity
Posts: 361
Noises stopped a day later, not sure if it was just a case of the fluid needing to work it way through the rack, because it is quiet again.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'