What I am assuming is a stuck ebrake

Reply

  #1  
Old 09-02-10, 11:26 AM
Member
Thread Starter
Join Date: Sep 2010
Location: USA
Posts: 1
What I am assuming is a stuck ebrake

I am driving a 91 ford tempo. it ran fine earlier with a few kinks and jerks when braking, but the car is very old and finicky. I am pretty sure the ebrake is stuck. the car takes way too much to go and quickly decelerates. the ebrake is completely down but im assuming it may be stuck somewhere else. the car was sitting for a while. when i came home i could smell rubber burning and now there is what looks like burn marks, yellowish tint on the rear passenger side tire only. any ideas? and if it is the e-brake, how can i fix it? please help!
 
Sponsored Links
  #2  
Old 09-02-10, 01:00 PM
ASE MASTER's Avatar
Banned. Rule And/Or Policy Violation
Join Date: Aug 2010
Location: USA
Posts: 560
(QUOTE) i came home i could smell rubber burning and now there is what looks like burn marks, yellowish tint on the rear passenger side tire only.

Based on the above, it does sound like the emergency brake is hung up. It has to be evaluated. The cable could be stretched, broken or need adjustment. You should also pull the brake drum on the said wheel and replace and worn or broken brake parts.
 
Reply


Thread Tools
Search this Thread
Display Modes
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 01:14 PM.