'96 Ford Contour check engine

Reply

  #1  
Old 09-05-10, 08:38 AM
Member
Thread Starter
Join Date: Nov 2004
Location: CA
Posts: 2,041
Received 0 Votes on 0 Posts
'96 Ford Contour check engine

This issue has been ongoing for ...well, years. It is more of an annoyance, and I am not inclined to spend a ton of money on this car...I only drive it 8 miles a day, and will just get rid of it when it dies. BUT, I would like to find out what's up:

When gas tank gets down near 1/4, check engine light comes on. When I fill up, light goes out after about 15 to 20 miles. Recently, the light comes on between 1/2 and 3/4 ! Still goes out if I fill up.

I have replaced the gas cap once, no change.

Any idea what is going on??

I tried Kragen/AutoZone, they used to read the check enging codes for you, but said the law doesn't allow them to to that anymore. Anytime I have had it in for oil change etc the light is not on.

Thanks,
 
Sponsored Links
  #2  
Old 09-05-10, 09:07 AM
ASE MASTER's Avatar
Banned. Rule And/Or Policy Violation
Join Date: Aug 2010
Location: USA
Posts: 560
Received 0 Votes on 0 Posts
Sounds like an e-vap or fuel pressure sensor issue. Need to see actual code. Your description of the problem (although good) does not give us enough information. Forget about Auto Zone. Pull your own codes. Go to Walmart super store. Buy "Equss Code Reader Model 3030". Good tool for the money. Worthwhile investment. Pull your own codes and post them.
 
  #3  
Old 09-05-10, 10:11 AM
Member
Join Date: Oct 2008
Posts: 1,312
Received 0 Votes on 0 Posts
Yes, they have gone to a lot of effort to get the engine computer (check engine light) to tell you what the problem is.

Get a code reader or go to a mechanic and have your code(s) read. Write down the numbers!
 
  #4  
Old 09-05-10, 10:58 AM
Member
Thread Starter
Join Date: Nov 2004
Location: CA
Posts: 2,041
Received 0 Votes on 0 Posts
Thanks very much for the feedback. I was hoping it would be a simple " here is the problem" !! I should realize cars are not that simple! I am just curious enough that I think I will spring for that tester, and see what it tells me. I will let you know.

Is the connector for that under the dash, or under the hood? I do have a Chilton's for the car, so probably that will show me.
 
  #5  
Old 09-05-10, 01:50 PM
Member
Thread Starter
Join Date: Nov 2004
Location: CA
Posts: 2,041
Received 0 Votes on 0 Posts
OK....yes, my connector is under the dash, on the left next to the door. I took it for a short drive to warm it up....and of course the light is now off, because it has been a few days! But I ran the tester, and it shows "freeze frame" and code
P0402. The book shows exhaust gas recirc excess flow. I am fixing to load the software that came with it, and supposedly on line it may give some suggessted repairs??

Thank you very much,

Being a real glutton for punishment, I sprung $14.95 for the "advanced diagnostic report" When I get that , I will let you know what it says.
 

Last edited by 594tough; 09-05-10 at 02:45 PM.
  #6  
Old 09-07-10, 08:19 PM
Member
Thread Starter
Join Date: Nov 2004
Location: CA
Posts: 2,041
Received 0 Votes on 0 Posts
I got back the report from Repair Solutions ( software that came with my code reader ).

most likely fix: inspect for faulty vacuum hoses at EGR valve.
I think I can at least take a stab at that.

2nd most likely fix: replace DPFE sensor. That looks like a job for my mechanic.


At least, I have something to go on now. I will talk to my mechanic, show him the diagnostic report, and then ask him to use his best judgement on how to proceed.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
 
Ask a Question
Question Title:
Description: