Has anybody had problems with different brands automotive air filters with flow

Reply

  #1  
Old 12-08-10, 12:40 PM
Member
Thread Starter
Join Date: Nov 2010
Location: USA
Posts: 23
Has anybody had problems with different brands automotive air filters with flow

I think my last air filter was bad?? The brand is one I never used before but it seems to be plugged or at least has a restricted air flow!

Does anybody had experience with this issue?

Thanks for your thoughts and feedback
 
Sponsored Links
  #2  
Old 12-08-10, 12:48 PM
Gunguy45's Avatar
Super Moderator
Join Date: Dec 2007
Location: USA
Posts: 20,804
Basic 1" filters or the thick 4" type? What was the brand/type of the one you used that restricted flow?
 
  #3  
Old 12-08-10, 08:23 PM
Join Date: Jun 2010
Location: Canada (near The Motor City)
Posts: 590
Why do you think it's plugged ??...
 
  #4  
Old 12-11-10, 07:19 AM
Member
Thread Starter
Join Date: Nov 2010
Location: USA
Posts: 23
Has anybody had problems with different brands automotive air filters with flow

Originally Posted by Gunguy45 View Post
Basic 1" filters or the thick 4" type? What was the brand/type of the one you used that restricted flow?
car quest basic type standard 1"
 
  #5  
Old 12-11-10, 07:21 AM
Gunguy45's Avatar
Super Moderator
Join Date: Dec 2007
Location: USA
Posts: 20,804
I must have been on an HVAC roll....I was thinking of furnace filters...lol.

To answer your question, I never use the house brand...could be because they never carry mine..but I usually use A/C, FRAM, or Purolator...normally one of them is on sale.
 
  #6  
Old 12-11-10, 07:31 AM
Member
Thread Starter
Join Date: Nov 2010
Location: USA
Posts: 23
Originally Posted by 2granddaughters View Post
Why do you think it's plugged ??...
That's a good question and the reason for the post- defective? When trying to blow air through it very little pass through. So rinsed it with hot water to see if dirt or anything else would come out oil soap etc zero. paper to dense??


Thanks for reply
 
  #7  
Old 12-11-10, 07:43 AM
Member
Thread Starter
Join Date: Nov 2010
Location: USA
Posts: 23
Originally Posted by Gunguy45 View Post
I must have been on an HVAC roll....I was thinking of furnace filters...lol.

To answer your question, I never use the house brand...could be because they never carry mine..but I usually use A/C, FRAM, or Purolator...normally one of them is on sale.
Thats OK thanks for your feedback---- me to Fram or something like that.Paper filters for other industries I'm familiar with (micron sizes ).This was use on a oil change questioned it then told it was OK.......never heard of any brand problems before with air filters on CARS!
 
  #8  
Old 12-11-10, 08:29 AM
Member
Join Date: Sep 2005
Location: York haven
Posts: 111
Originally Posted by dagresta View Post
That's a good question and the reason for the post- defective? When trying to blow air through it very little pass through. So rinsed it with hot water to see if dirt or anything else would come out oil soap etc zero. paper to dense??


Thanks for reply
It could be a bum filter, bad things happen, however rare, or one in a billion. Industry uses a manometer to monitor their filters, as an experiment, you could rig up a test.. This should be done at the Vol-Tech automotive training courses.
 
  #9  
Old 12-11-10, 08:57 AM
Member
Thread Starter
Join Date: Nov 2010
Location: USA
Posts: 23
Originally Posted by earthworm View Post
It could be a bum filter, bad things happen, however rare, or one in a billion. Industry uses a manometer to monitor their filters, as an experiment, you could rig up a test.. This should be done at the Vol-Tech automotive training courses.
replaced it......... I agree rare ..this was do to MPG problem with no resolve post 2005 jeep Grand Cherokee V8 4.7 poor gas mileage

Thank you for your feedback and thoughts
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'