navigator a/c issues

Reply

  #1  
Old 06-07-11, 06:20 PM
Member
Thread Starter
Join Date: May 2002
Location: ny
Posts: 229
navigator a/c issues

I had the compressor changed last summer and it worked well. This summer, it does not seem cold enough. Also. i noticed that it stops blowing out of the upper vents when rpm go up. The blowing continues when rpm come down.....
any ideas?
thanks
birch
 
Sponsored Links
  #2  
Old 06-08-11, 06:18 PM
Member
Thread Starter
Join Date: May 2002
Location: ny
Posts: 229
O.K. I tried the a/c on climate control today instead of straight a/c. It seemed colder but still not cold enough. Is it possible to try a bottle of freon before bringing it into the shop? How do i fill the system?

I know this reads very confusing, but the problem is not black and white. I'd rather try some less expensive options before bringing it to the shop.
thanks
birch
 
  #3  
Old 06-09-11, 04:36 AM
the_tow_guy's Avatar
Group Moderator
Join Date: Feb 2001
Location: SW Fla USA
Posts: 11,517
I don't know about NY, but around here, all the ac shops will do a free check for proper servicing. Although there are products on the market to DIY the servicing, personally I don't recommend it. The fluctuating air flow may be a vacuum leak in one of the actuators in the ducting system.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'