1995 altima knock sensor error code question

Reply

  #1  
Old 06-11-11, 11:05 AM
Member
Thread Starter
Join Date: Nov 2008
Location: Texas
Posts: 171
1995 altima knock sensor error code question

If my car throws the knock sensor code continually and the car is running like crap--do I just replace the sensor or is there something else I should look at first? Any help is appreciated
 
Sponsored Links
  #2  
Old 06-15-11, 09:40 AM
billys68ss's Avatar
Member
Join Date: May 2003
Location: USA
Posts: 1,459
The Knock sensor detects noise or imbalance in your engine. When it detects noise it sends a signal to the PCM to retard the timing to reduce the risk of engine damage. Therefore reducing the power and will also make it run poorly. The knock sensor could be bad or you actually have an internal engine issue that is causing the knock sensor to do its job. I would test the circuitry to determine functionality and if the wiring is ok then most likely you have a failed sensor.
Hope this helps ya,
Billy
 
  #3  
Old 06-15-11, 02:19 PM
the_tow_guy's Avatar
Group Moderator
Join Date: Feb 2001
Location: SW Fla USA
Posts: 11,596
If you have access to a timing light, you might also check the timing. As Billy mentions, the sensor or its circuit may have crapped and it might be a bad enough failure to be retarding the timing most or all of the time.

Silly question, but have you checked to make sure it's not simply unplugged/disconnected? It'll be screwed into the side of the block somewhere, not sure where on your particular car.
 
  #4  
Old 06-16-11, 04:41 AM
Member
Thread Starter
Join Date: Nov 2008
Location: Texas
Posts: 171
that knock sensor was on there very tight! The sensor casing was split so I am sure the code that was thrown was valid even though the sensor isn't the problem. car still sputters when warm--replaced the upstream oxy. sensor--old one was not screwed in tight at all! Then the distributor wire connector from the harmess crumbled so I am re-wiring a junkyard replacement--wish me luck on the test driveNo Beer 4U
 
  #5  
Old 06-16-11, 09:29 AM
billys68ss's Avatar
Member
Join Date: May 2003
Location: USA
Posts: 1,459
Did you replace the knock sensor? Split/broken casing on the sensor means it could send a bad signal causing the retarded timing. O2 Sensor will not cause a knock sensor code.
 
  #6  
Old 06-16-11, 04:16 PM
Member
Thread Starter
Join Date: Nov 2008
Location: Texas
Posts: 171
I did replace the knock sensor and the codes stopped. Still looking for reason why car misses when it drives for10 minutes or so.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes