Emergency Brake on 2002 Chevy Blazer

Reply

  #1  
Old 06-29-11, 12:27 PM
Member
Thread Starter
Join Date: Jun 2009
Location: USA
Posts: 1
Emergency Brake on 2002 Chevy Blazer

Have a 2002 Chevy Blazer 4x4 with 4.3 liter with 104k miles. It won’t pass safety inspection because when you push down the emergency brake the pedal goes down and stays but does not hold the Blazer in place. I replaced the disc pads because they were worn down almost to the sounding arms. But, still, no working emergency brake.
-garnb
 
Sponsored Links
  #2  
Old 06-29-11, 12:33 PM
Gunguy45's Avatar
Super Moderator
Join Date: Dec 2007
Location: USA
Posts: 20,792
The cable needs adjusting I would imagine? Either under the vehicle or at the pedal.

Autozone has instructions at their site...
 
  #3  
Old 06-29-11, 02:32 PM
lawrosa's Avatar
Super Moderator
Join Date: Dec 2010
Location: USA
Posts: 17,607
I would kind of agree with gunguy, but I have never adjusted a emergency brake cable in my life.

Did you bleed the brakes?
Is there fuid in the brake fluid resovoir?

I think there are seperate pads for the parking brake. Did you change those. Also I read something about rear calibers are aluminum and bind. Says they should be replaced. Although thats unrelated to the parking brake.

Also did you change the rotors? They may have been glazed and you need to scuff them up. If new then there is a set in procedure to set the pads and rotors. Otherewise you wont stop well.

Mike NJ
 
  #4  
Old 06-29-11, 06:24 PM
ukrbyk's Avatar
Member
Join Date: Mar 2010
Location: USA/ Pacific NW
Posts: 3,189
ahem... don't start me on GM parking brakes with one large shoe... ain't worth a flip on almost new cars; multiple complaints on them not holding in GM forums. my Silverado is the same way - goes down to the floor, and almost like it's not there. mine is 2000. i think they finally changed design, but generally it sucks.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'