95 jimmy no start


  #1  
Old 08-13-11, 07:42 AM
K
Member
Thread Starter
Join Date: Dec 2005
Location: ma
Posts: 97
Received 0 Votes on 0 Posts
95 jimmy no start

95 jimmy 4.3 250000mi. , after driving anyplace i come out start it but just cranks after couple times. so i leave it a few seconds and then it may start after a few tries. also can be drive down rode sometimes stalls for no reason. new fuel pump and sending unit last year. any thoughts as to where i should start looking at. thanks k
 
  #2  
Old 08-13-11, 10:48 AM
E
Member
Join Date: Mar 2009
Location: Texas
Posts: 1,051
Received 0 Votes on 0 Posts
Does the vehicle have OBD2 or OBD1 or OBD1.5. Checking for any diagnostic fault codes should be the first step and hopefully your vehicle was one of the first to have OBD2 depending on when it was built in 1995. We need to know what you can find out. There are a few possibile causes of your problem as you may know. Also what maintenance has been done on the vehicle in regards to ignition and fuel as a start point for the forum?
 
  #3  
Old 08-13-11, 01:43 PM
K
Member
Thread Starter
Join Date: Dec 2005
Location: ma
Posts: 97
Received 0 Votes on 0 Posts
its obd2 no codes, took short trip shut off and waited 10min and nothing just crank. put scanner on same time .started after a little rest but one of these little trips i know ill be stuck somewhere as it happened earlier this summer. a friend says it could be the pressure regulator.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description: