1999 Caravan Rough idle

Reply

  #1  
Old 02-21-12, 06:11 PM
Member
Thread Starter
Join Date: Jan 2006
Location: Canada
Posts: 31
1999 Caravan Rough idle

99 dodge caravan 3.0 L motor 6 cyl 98000 kms having problem with idling
sometime while stopping at intersection it goes high by itself ans sometime goes down and low oil warning comes on even though the oil level is perfect
any help will be appriciated
Thanks in advance
 
Sponsored Links
  #2  
Old 02-22-12, 05:12 AM
the_tow_guy's Avatar
Group Moderator
Join Date: Feb 2001
Location: SW Fla USA
Posts: 11,589
Could be a number of things causing that; idle air control (IAC), throttle position sensor (TPS), dirty mass airflow sensor (MAF) just to name a few. First off I think I would have it scanned for codes even if you're not getting a check engine light. Might give you a starting point. Is all your routine preventive maintenance up yo snuff - plugs, wires, filters, etc?
 
  #3  
Old 02-22-12, 07:34 AM
Member
Thread Starter
Join Date: Jan 2006
Location: Canada
Posts: 31
I changed oil and air filter yesterday i will drive and see if it would make any difference and then i will get it scanned
thanks for your help
 
  #4  
Old 02-22-12, 06:55 PM
Member
Join Date: Jan 2006
Location: Ontario, Canada
Posts: 759
Quite common for IAC ( idle air control) motor to get gummed up , especially on the pintle ( pointed end that seats inside throttle body housing) . Couple of torx screws hold it on. Remove electrical connector, torx screws and wiggle it out . Use throttlebody spray cleaner and clean pintle and shaft good, (dont move shaft leave it where it is) Then spray in port (hole) it came out of well to clean it as well. Carefully re-install ( watch the "O" ring at base of body.) and then try it. if it cures it for a while and then starts to act up again, replace the IAC. Spray inside throttle body opening as well and throttle plate to clean it up too.
 
  #5  
Old 02-22-12, 08:31 PM
Member
Thread Starter
Join Date: Jan 2006
Location: Canada
Posts: 31
Thanks Mike I will do that tomorrow and I think that will fix it
Thanks I will post back
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes