2006 Mitsubishi Galant

Reply

  #1  
Old 03-01-12, 11:55 AM
Member
Thread Starter
Join Date: Feb 2012
Location: usa
Posts: 2
2006 Mitsubishi Galant

Yes I hAVE A 03 GALANT. ABOUT A YEAR AGO, WHEN YOU TURN THE COLD-HEAT Control knob all the way to cold, sometime starts knocking in the dash, like behind the radio. If you click warmer two noches the noise stop. Any Ideas. Thanks JBLaine
 
Sponsored Links
  #2  
Old 03-01-12, 04:42 PM
Member
Join Date: Mar 2009
Location: Texas
Posts: 1,051
When was the last time you had the entire cooling system flushed and filled? A guess would be that there is some blockage restriction in either the heater rad or the coolant flow valve that controls hot flow into the rad. Are you getting full heat from the HVAC and have you had any over heating issues with the car? Could even be some trapped air in the system as well. I would start with a flush and fill if you haven't had it done, or don't know if it ever was done for that matter.
 
  #3  
Old 03-01-12, 06:54 PM
the_tow_guy's Avatar
Group Moderator
Join Date: Feb 2001
Location: SW Fla USA
Posts: 11,589
'Nox, I was thinking more on the line of blend door actuator problem like it's trying to move to the selected position but can't get there; obstruction, stripped/broken parts, etc.
 
  #4  
Old 03-04-12, 08:42 PM
Member
Join Date: Mar 2009
Location: Texas
Posts: 1,051
Could be Tow_ Guy, but it sounded more around the heater rad, and with a vehicle that old who knows what maintenance it ever had. I am also not sure with that vehicle if the actuators are vaccum or electric and whether that model has any history of actuator/blend door misbehavior. I hope we hear more from the OP.
 
  #5  
Old 03-05-12, 08:31 PM
Member
Join Date: Mar 2009
Location: Texas
Posts: 1,051
I did Google this problem and it seems that alot of people had failures with the heater control valve on this car. I am still guessing this is the OP's problem too.
 
  #6  
Old 03-08-12, 01:11 PM
Member
Thread Starter
Join Date: Feb 2012
Location: usa
Posts: 2
knocking noise in dash

2 months ago I replaced the radiator, u & l hoses, t-stat & heater hoses. The radiator upper tank split open. Have had no overheating problem, no no heat in car issuse either. just this strange noise. a/c doesn't seem effected either. thanks for your resposce. JBlaine the car is a 2003 Galant
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes