1999 subaru legacy sus

Reply

  #1  
Old 09-21-12, 06:35 PM
Member
Thread Starter
Join Date: Sep 2012
Location: United States
Posts: 2
1999 subaru legacy sus

I am having front defroster problems. The blower works but when defroster button is pushed it does not put air through the defroster vent. All the air comes out the dash and floor vents. What could the problem be? Thank you for any help.
 
Sponsored Links
  #2  
Old 09-21-12, 06:50 PM
ukrbyk's Avatar
Member
Join Date: Mar 2010
Location: USA/ Pacific NW
Posts: 3,189
anything from broken actuators to bad climate control unit.
 
  #3  
Old 09-22-12, 03:45 AM
Member
Thread Starter
Join Date: Sep 2012
Location: United States
Posts: 2
Would you happen to know a good web site for getting a schmatic for where the actuator and climate control is located. An actuator switch was replaced about 2 years ago. I was told it improved the problem but did not repair the problem completely. Thank you.
 
  #4  
Old 09-22-12, 05:45 AM
the_tow_guy's Avatar
Group Moderator
Join Date: Feb 2001
Location: SW Fla USA
Posts: 11,513
That's going to be a tough find. Climate control stuff is so specialized it often doesn't show up in standard repair manuals. AllData would likely have it, but it will cost you:

ALLDATAdiy.com Leading Source of Factory Automotive Repair Information
 
Reply


Thread Tools
Search this Thread
Display Modes
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 07:52 PM.