2000 ZR2 Blazer...Driver Wiper is not in sync...must be loose. How?


  #1  
Old 01-04-13, 09:43 AM
K
Member
Thread Starter
Join Date: Oct 2004
Location: alabama
Posts: 150
Received 0 Votes on 0 Posts
2000 ZR2 Blazer...Driver Wiper is not in sync...must be loose. How?

How would I go about fixing my loose wiper on the drivers side? I've raised it up and there is no screw to adjust. Should I take out the grill below (beside) the wiper? Should I just carry it to a mechanic? I am talking about the arm of the wiper. Does it just pop off? Should I just pull up on it real hard or force it? I think it has splines for wiper.
 
  #2  
Old 01-04-13, 11:42 AM
M
Forum Topic Moderator
Join Date: Mar 2005
Location: USA - N.E.Tn
Posts: 48,078
Received 398 Votes on 354 Posts
Exactly what is loose? Is the 'hub' that the wiper arm attaches to, moving when the other side does? Do you think maybe it's stripped? have you removed the arm for inspection? Usually you can just pop them off although some use a bolt or a clip.
 
  #3  
Old 01-04-13, 03:53 PM
ukrbyk's Avatar
Member
Join Date: Mar 2010
Location: USA/ Pacific NW
Posts: 3,645
Received 16 Votes on 13 Posts
Normally there's a cap covering arm to axle attachment. Remove the cap and there should be a tightening bolt, securing arm to the axle. If that nut is gone, here's your answer.
If the splines are worn out, you either have to replace the arm, or entire wiper assembly. Btw, thing is called cowl. Covers wiper assembly.
Or, you can JB Weld arm to the axle. Will hold for a year or so.

Sorry, not tightening bolt. Tightening nut.
 
  #4  
Old 01-04-13, 10:10 PM
K
Member
Thread Starter
Join Date: Oct 2004
Location: alabama
Posts: 150
Received 0 Votes on 0 Posts
Normally there's a cap covering arm to axle attachment. Remove the cap and there should be a tightening bolt, securing arm to the axle. If that nut is gone, here's your answer.
If the splines are worn out, you either have to replace the arm, or entire wiper assembly. Btw, thing is called cowl. Covers wiper assembly.

Yes...it is loose under the "cowl".... arm to axle attachment. I just don't know how to get the "cap" off.
Thank you for your help
Kyle
 
  #5  
Old 01-05-13, 08:12 AM
ukrbyk's Avatar
Member
Join Date: Mar 2010
Location: USA/ Pacific NW
Posts: 3,645
Received 16 Votes on 13 Posts
PM-d you..........................
 
  #6  
Old 01-05-13, 08:13 AM
ukrbyk's Avatar
Member
Join Date: Mar 2010
Location: USA/ Pacific NW
Posts: 3,645
Received 16 Votes on 13 Posts
btw, arm to wiper shaft attachment is above the cowl, not underneath it.
 
  #7  
Old 01-06-13, 02:12 PM
K
Member
Thread Starter
Join Date: Oct 2004
Location: alabama
Posts: 150
Received 0 Votes on 0 Posts
ukrbyk
thanks for your help
kyle
 
  #8  
Old 01-06-13, 07:47 PM
ukrbyk's Avatar
Member
Join Date: Mar 2010
Location: USA/ Pacific NW
Posts: 3,645
Received 16 Votes on 13 Posts
any time, friend. not sure if it's exactly same on yours, but GM is GM, it might as well be.
Have at it.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description: