1988 chevy k 1500 fuel pump wont run

Reply

  #1  
Old 01-18-13, 10:49 PM
Member
Thread Starter
Join Date: Jan 2013
Location: USA
Posts: 3
Received 0 Votes on 0 Posts
1988 chevy k 1500 fuel pump wont run

Recently replaced the fuel pump and it ran good for awhile . I jumped the fuel pump test terminal and it ran so got new fuel pump relay installed that and still no go. Also transmission hasn't been shifting into third for awhile not sure if maybe that caused this? I'm usually pretty good at the diagnostics but this has me stumped . Thanks and hope someone can help me,
 
Sponsored Links
  #2  
Old 01-19-13, 05:52 AM
the_tow_guy's Avatar
Group Moderator
Join Date: Feb 2001
Location: SW Fla USA
Posts: 11,831
Received 37 Votes on 29 Posts
I would hunt down a wiring diagram (try the repair section at autozone.com) to see if there are any other potential circuit issues. Oil pressure sender comes to mind; some vehicles have input from there so if you lose oil pressure the engine shuts down.
 
  #3  
Old 01-19-13, 08:58 PM
Member
Thread Starter
Join Date: Jan 2013
Location: USA
Posts: 3
Received 0 Votes on 0 Posts
Thanks a good wiring diagram would be most helpful and I'm on a tight budget. I recently replaced the oil sensor, fuel pump and I just replaced the oil pressure sending unit. Guess its time for the old multi meter also I hope this was the right forum as I wasn't sure if the no trucks applied to light pick ups or semi's? If this is the wrong one I do apologize!! Its my first time with any kind of forum stuff .Anyhoo thx ill let ya know if I can track it down
 
  #4  
Old 01-20-13, 08:07 AM
the_tow_guy's Avatar
Group Moderator
Join Date: Feb 2001
Location: SW Fla USA
Posts: 11,831
Received 37 Votes on 29 Posts
Not a big deal on which Forum to be in.
 
  #5  
Old 01-20-13, 08:30 AM
XSleeper's Avatar
Group Moderator
Join Date: Dec 2004
Location: USA
Posts: 23,463
Received 241 Votes on 222 Posts
Intermittant fuel pump can sometimes be attributed to a bad/corroded ground.
 
  #6  
Old 01-24-13, 04:33 PM
Member
Thread Starter
Join Date: Jan 2013
Location: USA
Posts: 3
Received 0 Votes on 0 Posts
ok Thank you I looked at autozone thanks for the tip !!!
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
 
Ask a Question
Question Title:
Description: