'05 Chrysler Town & Country Van No Heat

Reply

  #1  
Old 01-22-13, 09:49 AM
Member
Thread Starter
Join Date: Apr 2008
Location: New York
Posts: 68
'05 Chrysler Town & Country Van No Heat

I have an '05 Chrysler T&C van and in the past couple days there has been no heat even after it has been running a while. I have checked the fluids and everything is filled however I believe there is a small leak in the radiator and I put some Prestone radiator stop leak in it however it doesnt seem to have helped much. I dont know if maybe there is something wrong with the thermostat or something more. If anyone can help please do so as I would like to get this fixed so that I have heat again.

thank you,
niceguy4u36
 
Sponsored Links
  #2  
Old 01-22-13, 09:55 AM
Forum Topic Moderator
Join Date: Mar 2005
Location: USA
Posts: 44,030
What does your engine coolant temperature gauge say?
 
  #3  
Old 01-22-13, 09:58 AM
Member
Thread Starter
Join Date: Apr 2008
Location: New York
Posts: 68
The temperature gauge shows a normal temp...its not running hot or anything like that. It gets to about right in the middle of the gauge.
 
  #4  
Old 01-22-13, 10:00 AM
Forum Topic Moderator
Join Date: Mar 2005
Location: USA
Posts: 44,030
There is either an obstruction preventing the door that sends out the heat from opening [probably under/behind the glove box] or for some reason water isn't flowing thru the heater core. Most likely it's a vent issue.
 
  #5  
Old 01-22-13, 10:12 AM
Member
Join Date: Oct 2010
Location: USA
Posts: 563
I can't remember if that van has a valve to prevent coolant from cycling through the heater core when the heat isn't enabled or not. If it does, the stopleak might have gummed it up.
 
  #6  
Old 01-22-13, 07:16 PM
iceman681's Avatar
Member
Join Date: Jul 2012
Location: usa
Posts: 436
these are bad for the blend door motors going bad. but first make sure if both your heater hoses are both hot. if one is and the other is not, your heater core is plugged, if both cold, air and you need to fix your leak. if both hot blend door issues. if it has dual heat. check passenger side for heat to conform.
 
  #7  
Old 01-23-13, 08:34 AM
Member
Join Date: Sep 2012
Location: USA
Posts: 6
Wonder If your AC is working or not. If valve got stuck. Try banging a bunch of times on middle of dash. Believe it or not....it worked with one car.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes