ambient temperature indicator failing on 2004 Chysler Sebring Limited

Reply

  #1  
Old 06-27-13, 12:42 PM
Member
Thread Starter
Join Date: Mar 2002
Location: Iowa
Posts: 250
Thumbs up ambient temperature indicator failing on 2004 Chysler Sebring Limited

The temp indcator is on a slow march upwards..never resets just shows warmer.
Auto coolant/engine temp is good. Would this be an electrical short that allows it to fail upscale or a sensor failure? Approximate cost to repair or just ignore it?
 
Sponsored Links
  #2  
Old 06-27-13, 01:36 PM
Join Date: Jun 2010
Location: Canada (near The Motor City)
Posts: 597
How do you know the coolant temp is good? Why do you think it isn't indeed running hot?
 
  #3  
Old 06-28-13, 06:17 AM
Member
Thread Starter
Join Date: Mar 2002
Location: Iowa
Posts: 250
My thoughts were based on that they are two different sensors......ambient temp sensor is located behind the grill.......I believe engine coolant sensor is a probe type located in th cars coolant system.... still researching my problem, although I have learned the ambient sensor is cheap as an aftermarket part, but not sure about electrical disconnects, battery neg disconnect to install it.......it is a learning experience for sure
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'