Subaru Legacy Tranny Trouble

Reply

  #1  
Old 08-01-13, 08:03 PM
Member
Thread Starter
Join Date: Nov 2012
Location: usa
Posts: 7
Subaru Legacy Tranny Trouble

I have a 1999 Subaru Legacy GT 2.5 with an automatic transmission. The car only has 120K miles on it, but the transmission seems to have been "slipping" since about 75K miles, about 3-4 years ago. While driving, the shifting is generally OK, except when I "punch it", when it shifts hard. The other times that it exhibits this hard, "thumping" sort of shifting is when I am at very low speeds, such as when I'm slowly backing out of a parking space or slowing down to park the car. The frequency of this behavior seems to increase in warmer weather. A mechanic checked the transmission mounts, which were OK, felt the symptoms and quickly said "the transmission is slipping and needs to be rebuilt" (to the tune of $2400). I've been driving this car with these symptoms for 3-4 years now, and I'm wondering if any auto or Subaru expert has any other possible diagnosis. Thanks, Jerry
 
Sponsored Links
  #2  
Old 08-02-13, 04:48 AM
Member
Join Date: Jan 2012
Location: Canada
Posts: 2,541
Not a Subaru owner, but have had a few autos in my day.
Have you had the transmission flushed and filled yet?
$2400 sounds pretty steep.
 
  #3  
Old 08-02-13, 04:50 AM
Forum Topic Moderator
Join Date: Mar 2005
Location: USA
Posts: 43,023
I'm not sure the price is out of line - least ways not around here. When the tranny first started acting up I would have changed the oil/filter .... I'd still try it and hope that the last 3-4 yrs hasn't caused any real damage.
 
Reply


Thread Tools
Search this Thread
Display Modes
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 02:08 AM.