Instrument cluster (speedometer, Tachometer, Break & ABS light) is not working

Reply

  #1  
Old 09-18-13, 01:53 PM
Member
Thread Starter
Join Date: Sep 2013
Posts: 1
Instrument cluster (speedometer, Tachometer, Break & ABS light) is not working

Instrument cluster (speedometer, Tachometer, Break & ABS light) is not working while driving.

My video for my 2009 camry is here:
https://www.youtube.com/watch?v=kwMBLAEx29w

Toyota service center asked $6000 to replace wire harness and PROBABLY electronic control unit.

I found some posts, but the answers are not that clear to fix it.

My 2007 toyota camry abs light and brake light come on and my - Fixya

http://www.justanswer.com/toyota/6ru...ly-posted.html

Any comments would be appreciated.
 
Sponsored Links
  #2  
Old 09-18-13, 11:35 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 45,513
Welcome to the forums.

Instrument cluster (speedometer, Tachometer, Break & ABS light) is not working while driving.

Ok....if the problem goes away and the car is fine.....it's not the wiring harness. It may be a plug issue but it's not a defective harness.

I've worked on problems like yours before but not your exact problem and car. I've done work for dealers and service centers. It requires the wiring service manual for the car as the computer has to be checked while the problem is occurring.

I didn't see your problem specifically listed in Camry common issues.

In your video I see the tach spiking. When you're driving it doesn't move at all ? Are you driving and taking that video ? I see the brake light on and the speedometer not moving. I see the directional on and off.

If I had to give a blanket diagnosis for your car..... I'd say that the cluster is losing ground. You'll need to go to someone that knows vehicle electronics.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes