1995 voyager radiator fan stays on

Reply

  #1  
Old 10-06-13, 08:29 PM
Member
Thread Starter
Join Date: Oct 2013
Location: United States
Posts: 2
1995 voyager radiator fan stays on

When the ignition key is turned on the fan runs in high mode. I pulled the fan relay and the fan doesnt run so I thought the relay might be stuck on so I replaced it but it still runs high all the time. I got a new temp sensor but its hard to get to for replacement. The fan was replaced by a shop because the engine started overheating, this fixed the overheating problem but now the fan is on all the time and the shop doesnt know why.
 
Sponsored Links
  #2  
Old 10-07-13, 06:39 AM
the_tow_guy's Avatar
Group Moderator
Join Date: Feb 2001
Location: SW Fla USA
Posts: 11,575
My first thought is, is the fan running all the time causing any problems? Reason I ask is that I have an auxiliary cooling fan to supplement the engine-driven fan on my wrecker and I have it set up to come on with the key. Since you've already tried the relay, next would be the temp sensor. I know they can be in hard to reach places, but it's one of the suspects and you'll have to get it swapped out. Only other component in the mix is the computer; it's what sends the signal, after getting the info from the sensor, to the relay to close. If your regular shop can't troubleshoot that, you might want to try another shop.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes