1996 ford explorer squealing

Reply

  #1  
Old 11-24-13, 09:16 PM
Member
Thread Starter
Join Date: Nov 2013
Posts: 1
1996 ford explorer squealing

I have a 96 explorer AWD 5.0, it started squealing out of the blue so i changed the serpentine belt and the belt tensioner pully. Now it still squeals not near as bad more like a humming sound what else could it be
 
Sponsored Links
  #2  
Old 11-25-13, 04:11 AM
the_tow_guy's Avatar
Group Moderator
Join Date: Feb 2001
Location: SW Fla USA
Posts: 11,514
Check for an idler pulley (simple pulley between accessories that assists the routing of the belt over the other pulleys); their bearings go bad about as often as the tensioner. Also, if you didn't do it already, start it up with the belt off to confirm it's an accessory/belt noise and not something internal. Also ensure power steering reservoir is topped off and try listening with the ac on and off.
 
  #3  
Old 12-04-13, 10:09 PM
wrench191's Avatar
Member
Join Date: Dec 2013
Location: usa
Posts: 14
I found this to be easier than removing the belt to prove the noise is coming from belt or pulleys. Shoot some baby powder on belt when running. This will stop noise for a while.
 
  #4  
Old 12-05-13, 07:56 PM
ukrbyk's Avatar
Member
Join Date: Mar 2010
Location: USA/ Pacific NW
Posts: 3,189
Water pump.
Did I say - water pump?
 
Reply


Thread Tools
Search this Thread
Display Modes
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 10:54 AM.