1992 Mitsubishi Expo Transmission problem


  #1  
Old 12-14-13, 06:07 PM
G
Member
Thread Starter
Join Date: Dec 2013
Location: us
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
1992 Mitsubishi Expo Transmission problem

I have an 1992 Mitsubishi Expo LRV 1.8ltr, 4 speed F4A22 Transmission.
Put it in reverse one day, it gave a little squeal and now I only have 1st and 3rd gear. No Revers, 2nd or 4th (od). Anyone have any ideas on what the problem may be and how to solve it.
Many thanks!
 
  #2  
Old 12-15-13, 07:57 AM
ukrbyk's Avatar
Member
Join Date: Mar 2010
Location: USA/ Pacific NW
Posts: 3,782
Received 45 Likes on 36 Posts
Oh man, what a great car!! I am envious, we had 1.4L one. Parted with her at close to 300 000 miles, was go anywhere little van.
Sorry, boss. Basically, the only thing you can do is to replace ATF and pray. It's likely transmission gone kaput.
 
  #3  
Old 12-15-13, 09:38 AM
G
Member
Thread Starter
Join Date: Dec 2013
Location: us
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
I have a spare transmission but it's a F4A23 with a different TCM. The wiring harness for the TCM is different as well (2 plug instead of 3). Is there anywhere that you know of for me to check if the TCM for the F4A22 will work with the F4A23. Many thanks.
I have a 1992 Eagle summit hatchback with 501,000 on her. I'm fixing to rebuild the engine and keep driving it. It's ugly but it gets 42 MPG.
Many thanks.
 
  #4  
Old 12-15-13, 08:28 PM
ukrbyk's Avatar
Member
Join Date: Mar 2010
Location: USA/ Pacific NW
Posts: 3,782
Received 45 Likes on 36 Posts
Oh yeah, those old Mitsu-s. Toss in famous Dodge Colt.
I'd say, change ATF and then consider getting a used transmission of the right kind. They are not expensive. You seem to be DIY enough to drop it in.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description: