ccoleman 12v tire inflator

Reply

  #1  
Old 12-27-13, 09:25 PM
Member
Thread Starter
Join Date: Sep 2012
Location: usa
Posts: 30
ccoleman 12v tire inflator

My coleman tire inflator ( 250 psi with pressure gauge and light) does not blow air (or little air). The motor is running. Last time i used it was about a month ago to inflate the front tires of my honda odessey. Could anyone tell me whats wrong and how to fix it. thank you
 
Sponsored Links
  #2  
Old 12-28-13, 01:17 AM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: NJ - USA
Posts: 43,483
It would have to have some kind of valves or reed plate that sounds like it's worn out.
However, I haven't found any replacement parts for those inexpensive coleman compressors.

Coleman advertises replacement parts for their units but I didn't find any actual motor/pumps parts available.

You could try at eReplacement.com for parts.
 
  #3  
Old 12-28-13, 06:13 AM
Banned. Rule And/Or Policy Violation
Join Date: Apr 2013
Location: USA
Posts: 4,297
Got a model #? Hard to suggest how to fix something with out at least that.
 
  #4  
Old 12-28-13, 08:00 AM
ukrbyk's Avatar
Member
Join Date: Mar 2010
Location: USA/ Pacific NW
Posts: 3,208
Why bother? They are dirt cheap at Walmart or Harbor Freight. Just get a new one. Btw, fix the leaking tire....
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'