need some help -1993 buick lesabre

Reply

  #1  
Old 01-17-14, 05:47 PM
Member
Thread Starter
Join Date: Jan 2014
Posts: 1
need some help -1993 buick lesabre

I tried starting up the 1993 Buick LeSabre this morning and it was sluggish, and later it would not start like the battery died; then I tried it again and it started; I took it to a mechanic and he said there was nothing wrong with the alternator or starter - that it might be the battery cables or a slight electric problem. Please advise. Thank you.
 
Sponsored Links
  #2  
Old 01-17-14, 05:51 PM
Member
Join Date: Jul 2013
Posts: 58
how old is the battery? you can get the battery tested for free at an auto parts store as well.
 
  #3  
Old 01-17-14, 07:02 PM
CasualJoe's Avatar
Member
Join Date: Jan 2010
Location: USA
Posts: 9,275
I took it to a mechanic and he said there was nothing wrong with the alternator or starter - that it might be the battery cables or a slight electric problem.
So, did he clean the connections? What did he recommend or did he just throw up his hands and say, it might be.......
 
  #4  
Old 01-17-14, 09:59 PM
ukrbyk's Avatar
Member
Join Date: Mar 2010
Location: USA/ Pacific NW
Posts: 3,222
Sometimes you might as well listen to mechanic.
 
  #5  
Old 01-18-14, 05:37 AM
the_tow_guy's Avatar
Group Moderator
Join Date: Feb 2001
Location: SW Fla USA
Posts: 11,541
Cables/connections, especially if one or both have been replaced by the cheap bolt on replacement cable ends; They're notorious for corroding around the cable-to-end connection.
 
  #6  
Old 01-22-14, 06:24 PM
Member
Join Date: Jan 2014
Location: USA
Posts: 7
Check the connections on the battery terminals are tight
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'