1988 Isuzu Trooper II 2.6L starts for a few seconds.

Reply

  #1  
Old 02-28-14, 12:43 PM
Member
Thread Starter
Join Date: Feb 2014
Location: us
Posts: 2
1988 Isuzu Trooper II 2.6L starts for a few seconds.

The 2.6 starts then shuts off . the fuel pump is working on start up, but seems to quit when engine starts running. all the dash lights are on also. All help appreciated. Thanks guys.
 
Sponsored Links
  #2  
Old 02-28-14, 02:26 PM
the_tow_guy's Avatar
Group Moderator
Join Date: Feb 2001
Location: SW Fla USA
Posts: 11,515
Possible you have an oil pressure sender issue. Some vehicles (like my Isuzu-chassis Chevy W-4) route the fuel pump circuit through the oil pressure sender after start up.
 
  #3  
Old 03-04-14, 11:02 AM
Member
Thread Starter
Join Date: Feb 2014
Location: us
Posts: 2
Thanks tow guy will check it out and let you know. Thanks.
 
  #4  
Old 02-18-16, 10:12 AM
Member
Join Date: Sep 2009
Location: GA,USA
Posts: 194
Wondering if tgregory ever got this issue resolved? Anyone with this model Trooper, the fuel pump is initially run from a battery circuit but just after starting I'm told power switches and runs straight from the alternator. His problem may have been a bad alternator?

Visit planetisuzu.com forum for more detail on this issue, there's lots of posts there on these.
 
  #5  
Old 02-19-16, 04:11 AM
the_tow_guy's Avatar
Group Moderator
Join Date: Feb 2001
Location: SW Fla USA
Posts: 11,515
Those were his only two visits here, hasn't been back since.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'