Service Engine Soon Multiple Codes

Reply

  #1  
Old 06-13-14, 03:08 PM
jimbfla's Avatar
Member
Thread Starter
Join Date: Jun 2014
Location: USA
Posts: 7
Service Engine Soon Multiple Codes

I have a 2001 Buick Century with 3.1 engine. I have 3 codes appearing, P0327 Knock Sensor low input, P0336 Crank position sensor A, P0341 Cam position sensor A. The car starts and runs OK, Would one bad sensor cause the other codes to appear, which one should I replace first, or is there a real problem in the engine? Lots of questions...Thanks.
 
Sponsored Links
  #2  
Old 06-13-14, 07:14 PM
iceman681's Avatar
Member
Join Date: Jul 2012
Location: usa
Posts: 434
a cam sensor could cause the others with out causing a noticeable running issue. also the easiest to do.
 
  #3  
Old 06-14-14, 03:13 AM
Member
Join Date: Jan 2014
Location: USA
Posts: 699
Before replacing sensors , I would check the wiring going to them , first . Then the connectors where they plug in ( clean and plug them back in ) .

I had a code on a 1996 Lumina 3.1L with a code for crank shaft position sensor . Turned out to be a broke wire , neat the connector . Do not know if it is the same 3.1 L as yours ? Bur , with different model year , that can make a difference , too ?

I could clear the codes by disconnecting one of the battery cables . Then see if codes come back ?

Best of luck :-)
Wyr
God bless
 
  #4  
Old 06-14-14, 07:53 AM
ukrbyk's Avatar
Member
Join Date: Mar 2010
Location: USA/ Pacific NW
Posts: 3,192
OBD-II Trouble Code: P0327 Knock Sensor Circuit Low Input (Bank 1)

Please, keep in mind, CIRCUIT is also involved.
I just had mice chew my sensor harness, to the grand of $360 in repairs.
Just like Wyr mentioned.
 
  #5  
Old 06-14-14, 08:47 AM
jimbfla's Avatar
Member
Thread Starter
Join Date: Jun 2014
Location: USA
Posts: 7
Thanks for the replies. I just viewed a video that showed damaged wires causing codes. That will be my first check.
Enjoy the day!
 
  #6  
Old 06-15-14, 03:53 AM
Member
Join Date: Jan 2014
Location: USA
Posts: 699
We have a 1991 Caprice that belonged to my late dad . We parked it at my brother in law's place , in the country . After 10 - 15 years , it id a continueing story , repairing things that have gone bad with that amount of neglect . :-(

Still finding wires the mice chewed on . :-(

To date , I have repaired the wiring going to the Throttle Position Sensor , Coolant Temperature Sensor and the Right Front ABS Sensor . I suspect more fun under the dash ?

God bless
Wyr
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'